Community Remote, first native Linux GUI for Roon, also on Raspberry Pi

I have something for all Linux users within the Roon Community that like to have a GUI that provides quick access to your Roon system. It is called Community Remote and it is developed in Flutter to also allow support for other platforms (only Linux and Android at the moment).

As there are a lot of distributions and package formats for Linux, I choose to pick one universal one, being Flatpak. You can read about Flatpak installation for your distribution here.

As a counter part to Flatpak there is Flathub, which is an online repository of available applications and Community Remote was added to it!


Here is a direct link to the Community Remote page on Flathub:

Depending on your distro and Flatpak installation you might also be able to find the Community Remote Flatpak directly in the software installation tool of your distro.

Regarding the provided functionality of Community Remote, I leave that for you to discover for the moment, it is meant to be intuitive :slight_smile:. In follow up posts I can share my favorite features, but feel free to share what you discovered and like, and what you would like to see added.

Remember that, as with any third party controller for Roon, the functionality that can be provided is limited by the Roon API.

Let me know your experience with installation and usage, and together make a useful tool of this.

22 Likes

One addition, after installation make sure that you enable the Community Remote extension via the official Roon Remote: Hamburger menu → Setup → Extensions.

I’ve got the panel open on my Linux box, but the “Community Extension” doesn’t show up in my Roon Remote, under Setup/Extensions.

If the app is running then it probably states in the top bar that there is no server paired. The server discovery method, as provided by the Roon API, is used, so it can be that a firewall or network subnets are in the way. One thing you can try is select the button in the lower right corner (having a link icon), it will give you the option to directly enter the IP address and port of your Roon server.

What distro are you using?

Xubuntu. What port should I enter? I’m running the server on my NAS, but I seem to have successfully authorized Roon TUI on this Linux box.

Tried ports 9331 and 9332, still no extensions reported as found in Roon Remote.

If you open Settings → Displays in the Roon Remote it shows the port number in the Web display URL. If no port number is provided it uses 9330 as the default.

Of course, why didn’t I think of that? :face_with_open_eyes_and_hand_over_mouth:

OK, the URL in Displays says port 9330, so tried that, still no joy.

Tried restarting flatpak, and now it discovers automatically. Woo-hoo! Seems to be working. Another Rust victory.

2 Likes

That’s good to hear! Now I’m officially not the only one who has ran it.

3 Likes

It installed cleanly on my Ubuntu 20.04 system. Excellent start!

I’m having trouble scrolling through the zones for zone selection (I have a lot of zones).

Will play with it some more but my first impression is appreciation for a first release that seems to work out of the box. Thanks Man!

1 Like

Developers who wish to contribute to this MIT licensed project can find its git repository at https://github.com/TheAppgineer/community_remote. Seems like a worthy candidate for contributed community effort.

p.s. I am not the maintainer or associated with the project. I’m just a fan.

2 Likes

Installed via Flatpak and running on Linux Mint Cinnamon 23.1. Took a couple of restarts for it to be recognised in Extensions. The Pick a Random Album is an interesting feature. Great effort and thank you @Jan_Koudijs

1 Like

Good point, I have only 4 zones, so I don’t reach the point that scrolling is required and therefor never tested this. Is there no scroll bar provided at all?

I will look into this.

Yes, Community Remote is fully Open Source.

I added some basic instructions in the README for those who want to build the project from the sources. Being a Flutter project it can be built for different platforms, but only Linux and Android are tested. So if some Windows developer wants to try to build it for Windows, go ahead and let me know how it goes.

One of the features you do not find in the official remote. Using Random Album or Random Track you can fill up your Queue for a lazy listening session :slight_smile:. If you select the Pick Random row the random item will be queued, but you can also open the drop down menu to select a specific action.




There are at least 2 other features unique to Community Remote :sunglasses:

1 Like

It’s a shame Danny never went back to work on the API. Would be nice to have it more full-featured.

2 Likes

Totally agree. Had the idea of filing a feature request for extending the Roon API, but haven’t got to it yet. When this exists every extension user / developer can give one of his votes to hopefully draw some attention. The Roon team can really start with small things like clearing the queue.

3 Likes

Installed without problem on my LUbuntu :

            .-/+oossssoo+/-.               zabodarski@plitvice 
        `:+ssssssssssssssssss+:`           ------------------- 
      -+ssssssssssssssssssyyssss+-         OS: Ubuntu 24.04 LTS x86_64 
    .ossssssssssssssssssdMMMNysssso.       Host: 4291K30 ThinkPad X220 
   /ssssssssssshdmmNNmmyNMMMMhssssss/      Kernel: 6.8.0-31-generic 
  +ssssssssshmydMMMMMMMNddddyssssssss+     Uptime: 21 mins 
 /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/    Packages: 2737 (dpkg), 7 (flatpak), 14 (snap) 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Shell: bash 5.2.21 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   Resolution: 1920x1080 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   DE: LXQt 1.4.0 
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   WM: Openbox 
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   Theme: Breeze [GTK3] 
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Icons: ePapirus [GTK3] 
 /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/    Terminal: qterminal 
  +sssssssssdmydMMMMMMMMddddyssssssss+     Terminal Font: Ubuntu Mono 10 
   /ssssssssssshdmNNNNmyNMMMMhssssss/      CPU: Intel i5-2520M (4) @ 3.200GHz 
    .ossssssssssssssssssdMMMNysssso.       GPU: Intel 2nd Generation Core Processor Family 
      -+sssssssssssssssssyyyssss+-         Memory: 1648MiB / 3797MiB 
        `:+ssssssssssssssssss+:`
            .-/+oossssoo+/-.                                       

Just this small trace at launch, without impact :

zabodarski@plitvice:~$ flatpak run com.theappgineer.community_remote
MESA: error: ZINK: failed to choose pdev
glx: failed to create drisw screen

That said, like Ronald I have a little problem with my 14 zones.

Bravo Jan, dp.