Complex issues with Live Radio!

The issue:
Live Radio cuts after few seconds or minutes after playback In my case this basically happens with all stations. So far. The issue is only observed on the PS Audio Bridge II endpoint and does not occur while using other endpoints such as Google Home speakers or the PS Audio Directstream DAC with USB connection.
Roon ROCK core PC with ethernet connection from Cisco switch to JCat Netcard Femto (dual ethernet card). Roon endpoint is PS Audio Directstream DAC connected via Bridge II from the the 2nd ethernet port on the JCat card. Connection between Roon Core and Bridge II is set with fixed ip addresses and, respectively.

  1. I use streaming from Qobuz and Tidal without any issue but Roon Live Radio is not working properly and always cuts between 20 to 60 seconds after starting while using the PS Audio Bridge II endpoint. In contrast, as mentioned before, LiveRadio plays fine when Roon Core is connected to the Directstream DAC via USB.

I have a friend who is using the exact same Roon Core setup with the JCat Card but does not experience the Live Radio problem that I have. The only difference is that his endpoint is a Moon 280D with MiND streaming module. Also, another person I know who uses the PS Audio Directstream with Bridge II and JCat Netcard Femto does not have any issues with Live Radio. The only difference between our systems is that he is using a Roon Core installed on a Windows PC and created a network bridge between the two internet ports on the JCat card.

  1. Another strange behavior for LiveRadio is between same station streaming from Live Radio vs My Live Radio under different urls.
    For example, Radio Paradise from Live Radio systematically cuts after 20-60 second after start. I tested this 5 times in a row. Right away after switching to “My Live Radio” where Radio Paradise was added manually a long time ago using the url, everything plays fine and consistently without interruption. The only difference between the two urls are “http” in MyLiveRadio vs “https” in LiveRadio .

Similar observations for other stations like:

Could you please help me to fix this quite inconvenient issue in Roon?

Note: I even found the station Rondo Classic Klasu Pro with same url in both LiveRadio and MyLiveRadio with only the one manually entered in MyLiveRadio plays well. The one from LiveRadio cuts after a few seconds

As you surmise, I can’t see anything wrong with the radio stations - they all appear to be set up OK; the .m3u and .pls files breakout into the other streams that you show.

(BTW - use the…/flacm stream for Radio Paradise, it gives you metadata).

The problem does seem to be with a combination of live radio and the PS bridge/JCat in your setup which makes no sense to me.

I’m moving this to the #support category where Roon’s @support will deal with it.

(Silly question, but always worth asking - have you rebooted everything?)

Thanks. Unfortunately, rebooting a few times did not fix the problem.

You are probably suffering from routing problems. These addresses are in public use and not reserved for private networks.

1 Like

If there is a way to connect the Bridge II to the second ethernet port (while ideally keeping it isolated from the rest of the traffic on the network). I would be happy to try.
On the other hand, keeping the same connection, it remains a mistery that I have been listening to Rondo Classic - Klasu Pro from MyLiveRadio for almost 2 hours without interruption while just switching to the same station from LiveRadio (same url !!!), makes the music to stop repeatedly after just a few seconds…

Use addresses (networks) reserved for private networks.

Unfortunately, changing to private ip adresses does not fix the problem.
I tried & and also & but the issue remains exactly the same.

Thank you. Now at least you can be sure that data isn’t sent to some place in the Ukraine.

This might be a problem for you. Such a setup i not possible with ROCK.

How many network interfaces are there on your Core (physically)? Should be at least one on the MB and two from your card. So three? Can you see all of them on the ROCK setup page?

Can someone with a PS Audio Bridge II confirm if that device operates correctly without connection to the internet?

A good test would bee to change network settings of the PS Audio Bridge II to use DHCP and connect it to your router or switch like your Core, PC, …
If the problem with Live Radio is gone then all is fine and you should consider to use your device like that in the future.

If you want to try and make your device work with the additional network card you should look into the #tinkering section of the forum as this kind of setup isn’t recommended or supported AFAIK. Also a search for JCat might reveal threads from other owners of that network card, providing additional insight.

Thank you for your suggestions.
For the first question, there are 4 different ethernet ports (2 on JCat card and 2 on MB) that I can see from the ROCK setup page with only 2 active connections on the JCat.
My setup was based on info found on the PS Audio forum where it was mentioned that it is possible to use direct internet connection from ROCK to the Bridge II: Direct connection of Rock Server to Direct Stream Junior Bridge (without internet router) - #6 by holzohr - DACs - PS Audio
That led me to this thread on the Roon community website where Danny Dulai (Roon Labs COO) explains how to setup ROCK with dual Ethernet connections.
ROCK Dual Ethernet - Primary Port Not Exposed [RESOLVED] - #16
Some people on this thread confirm that this is working and claim that there is an improvement in sound quality due to complete IP traffic isolation.

To address the other point, I tested the connection of the PS Audio Bridge II with DHCP but the LiveRadio still cuts. The only difference is that the stations play a bit longer than before (up to 2-2:30 min vs < 1min). I even tried to bypass the optical switch and connect the Bridge II directly from the router but the problem remains the same.

This morning I tested station “1.FM: Otto’s Baroque Music” using the 4 different streams available on LiveRadio and again… they all stopped after less than 1 min. I went to 1.FM web site using Chrome to inspect the Otto’s Baroque Music live stream and extracted the following url:

Went to MyLiveRadio, added a new station with this url and guess what … the station 1.FM: Otto’s Baroque Music (with metadata) has been continuously playing for more than 2 hour no problem!!!

Also, like I said before even the station Rondo Classic Klasu Pro with the same url, is not working from LiveRadio but works perfectly fine from MyLiveRadio added manually!!

In conclusion, after all these tests, I now have a hard time believing that my setup is the cause of the problem and that my case is an isolated one. There should be something different in the way Roon manages LiveRadio vs MyLiveRadio…

I really need someone from Roon Support to give me hints on how to fix this!! Help please!!

With what hardware? As I see it, PS Audio is well aware of potential issues with timing and noise. Their products seem to be well engineered, especially to overcome/prevent the potential issues mentioned before to become real ones. If I had hardware from PS Audio I wouldn’t waste my time on a network setup like yours.

I currently don’t have issues with Live Radio (currently listening to 1.FM - Adult Urban Hits) and the forum is also not full of complaints.

As you claim that all works well when you use USB, a faulty ROCK (Codec) is eliminated as a cause.
As Live Radio is streamed from the internet to the Core and from there to the endpoint, there is much networking involved. Your home network or your internet access is nothing Roon can do anything about. Best is simplify to the bare minimum to exclude as many potential sources of issues as possible.

If you connect the ROCK directly to the router also, so that both devices are directly connected to the router, this would be the bare minimum.

Another usually asked question is, if you have other endpoints that you (temporarily) can use, like a phone, tablet, desktop PC, … and if you see the same issues arise when you play to one of those.

These are just possible troubleshooting steps that you can undertake while waiting for official support, so you already have answers should they come back to you.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.