Complicated UX navigation failure

Nucleus, Eero WiFi, iPad remote, MicroRendu/Benchmark zone.

I had been on my home page, clicked on an album, hit Play.
Then I switched to another app, Safari probably.
Switched back to Roon. I was on a blank page, with the Now Playing banner on the bottom but nothing else and no navigation arrows in the top left.

I hit the NP banner and got to the Now Playing Page, it had the Upper-left X and the bottom-center down arrow but neither worked. It was as if the memory of the previous page was corrupted because the previous page was corrupted.

So I couldn’t get back from this page with the normal buttons. But I could get away from it, by clicking on the album name. This took me to the album page, but still no back arrow, the previous-page memory is corrupted.

Seems like all of this is results of the display being corrupted when I switched to another app and then back (which I of course do all the time, like now :grinning:).

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.