Composer Info is not showing

Content you’re reporting an issue with

Information about most composers is not loading

Have you made any edits to this content in Roon?

No

Is the album identified in Roon?

No

Is this content from local files, TIDAL, or Qobuz?

Local flac files

Screenshot of import settings



Description of the issue

I have Musopen collection of classical works imported into Roon. All composers except Bach do not have any information on their pages. For example, here is the details page for Mozart:


Interestingly, everything loads fine for Bach:

This is how Mozart’s files are tagged:

And this is Bach:

I checked for any weird non-ASCII symbols in tags and everything seems to be OK.
In the Artist Editor everything is set to “Prefer Roon data”

I connected Qobuz and it finds two Mozarts now:


mine without info and with full info from Qobuz.
I tried to manually re-enter composer in file tags but it didn’t change anything

I am pretty sure you are experiencing the behavior described here:

1 Like

I’m sure what @Suedkiez has described is what has happened here. The albums you imported were not recognised by Roon, and false composers have been created.

You can correct this by Merging the Composers, when you have the “real” composer appearing in your library (as you are now seeing for Mozart) - select the two, and then you will see a “Merge composers” button in the top right of the Roon screen.

1 Like

Yes, it is exactly this issue.
However, it looks like I don’t even need to manually merge them. Just adding a streaming album to the library and removing it right away fixes the composer issue. Adding an album with tracks from multiple composers fixes all of them.

Thank you!

1 Like

Interesting, I never noticed. Will try next time, thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.