Composer information is not displayed

There are rare albums in which composer information is not displayed on roon.
As shown in the first screenshot, all the composer information is entered in the audio file.
However, as shown in the second screen shot, roon does not display them at all.
I tried “Re-Scan Album”, “Re-Identify Album”, “Re-Analyze Album”, but I did not improve at all.

What have you selected in the Settings for “Show Composer Credits”?

This is what I see for the O’Jays album:

It looks as though Roon’s metadata does not include the composers for all tracks on this album, just the arrangers. Something for @joel to report back to Rovi, perhaps?

Edit: and this is what Musicbrainz has for the album - a somewhat different list of credits…

Reply Thank you.
“Show Composer Credits” Default or Always.
Composer information is written in the metadata of the audio file, but it is not displayed by Roon.

It is a 2010 release with a bonus track.

Musicbrainz did not have a corresponding album.

I think that Roon uses Allmusic data and Musicbrainz data, but can not use file metadata if the corresponding disc does not exist in Musicbrainz or incomplete information What?

if you want Roon to use your tags you must tell it to via settings.

Does Roon do not have the option of “using” or “not using” the composer information metadata of the file?

Hey @currycooqoo,

In Settings > Library > Import Settings there is an option for Composer Credits under Metadata preferences for tracks. You can choose Prefer File here if you want to use composer credits from your file tags.