Connect issue with Roon app when changing access point [Solved]

When i open the Roon app in the same room where Roon is running on my laptop and an wifi router resides it immediately connects. When I move with the ipad to the livingroon the connections is lost and it takes minutes to reconnect.

Is this issue known and can it be solved?

How’s signal strength and quality in the living room?

Excellent. There is another WiFi access point using the same SSID. Full strength

Can you let me know a bit more about your network configuration and access points?

We can definitely look at improving our performance here, but we need to be able to reproduce what you’re describing. The more details you can provide the better.


Thank you for taking this serious. I have several wifi routers spread across the house to provide proper wifi coverage. All routers are connected by cable. One router is configured with dhcp the others have it turned of. All routers are configured with the same wifi ssid. When moving around the house all mobile wireless devices seamlessly connect to the router with the strongest signal.

Roon though loses its connection and most often finds the roon host after a few minutes (which when waiting for it is really long ;-). Sometimes it doesn’t find it at all and restarting the roon host and roon app seem to speed up things.

Hi wappie,

Does the Roon host on your laptop have a fixed IP address ? If not I’d suggest giving it (and maybe the iPad) static IP addresses and seeing if that helps.

Is each router setup to do NAT and its own mini network? If so, your machines can’t talk to each other because of the 1-way nature of NAT. You basically have a bunch of little mini networks, which is fine if everyone talks to the internet, but bad if they want to talk to each other directly.

Either you need to:

a) punch holes in the NAT
b) segment each router to be on a different subnet
c) set your core to be a static IP inside that range
d) configure roon to use that static IP


a) flatten your network by setting each wifi router to be a bridge
b) have 1 router do your NAT from local LAN to internet

From your comment about DHCP being turned off, it seems like you may already have setup everything like option 2 above.

Can you confirm that everyone is on 1 IP network and not a bunch of little ones? Also, that your routers should be setup to bridge, not NAT.

I can confirm that option 2 is my case. They are all on the same network and eventually it does work when moving around so network and routing wise it works (and I never have had any other issues).

I still have to try converting to static IP addresses although, knowing how networking works, it does make sense to me as a solution direction.

Edit: The only router of which the WAN port is used is the one with the internet connection doing NAT. The others are connected via their normal LAN ports but broadcast the same SSID en are on the same network with IP numbers issued by the WAN connected router.

ok, in the broken state, can you tell me the ip addresses and netmasks of both the roon core and the roon remote? also, can you ping the roon core from the roon remote?

i just want to confirm that traffic is flowing between the two machines

if all is good, i would suggest you try setting up the roon core with a static ip, and then entering that ip into the ‘why cant i find my core’ input box – that will force the remote to scan at that ip.

I gave the Roon core host a static IP number ( Using Net Analyzer on the ipad I started a ping and moved around in the house. The ping was continuous. With the Roon remote ( open in the same room as the Roon core host I got an immediate connection. Walking to the livingroom Roon remote lost the connection however Net analyzer was still pinging.

As the iPad is issued an IP address by the DHCP service on the main router, moving around the house doesn’t change it as it lifetime has not expired.

any ideas?

Edit; I assume this scenario could be easily repeated in a test environment.
Edit 2: Isn’t the only thing that changes when hopping to another router the mac address that is seen at the Roon core. Is the Roon remote - core connection depending on that mac address and if it changes it needs to time out before being able to setup a new connection? just some thoughts
Edit 3: Entering the Roon core host IP number in the Roon remote scanning field does not find the host. It keeps saying looking for host…

When you type in the ip, it adds it to the explicit scan list, instead of relying on scanning via broadcast/multicast/guessing/tryingall.

So, if you typed in the IP, your remote would send a UDP packet to that IP, port 9003 – the core should see that packet and send a response with a lot more information, at which point the remote would make various TCP connections back into that same IP.

If you can ping, it means there is some form of connectivity. Is it possible firewalls are involved or your routers are blocking the UDP 9003?

MAC addresses should not matter.

I turned the FW on the Roon core off but no difference. I’ve netgear WNDR3700 and 3800 routers besides that I cannot see any firewall settings I don’t expect them to have firewalls enabled on the internal network.

If there would be a problem with UDP 9003 than it should not work ever I suppose but it does after minutes.

I must have missed something… on the other SSID, it works, but just after a few minutes?

All three routers have the same SSID. When walking around in house and the iPad connects to another access point (same SSID) (because of the stronger signal) Roon remote will lose its connection. If you wait long enough though (minutes) it will find the Roon Core again. Entering the IP adress manually does not speed things up.

First reaction after installing the latest update is that the problem is solved. Any idea if it was indeed identified as a problem and solves as a result? Will do some further checking. Thank you for your support and responses. Much appreciated

Edit: I confirm the problem is solved with the latest Roon version