Connecting from MacBook pro to Oppo BDP 203 Streaming Can't connect

I can’t seem to get my network set up between my core on the Apple MacBook Pro which is running roon and Tidal successfully and I can hear it on my computer. I updated the BDP 203 but can’t wirelessly set up a network so I can stream to the Oppo. Please help.

Hello @Grant_Grover — Thank you for your report!

To start, may I ask that you Please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Just to confirm, the Oppo device is the only zone you’re experiencing this with, correct? Was this happening before you updated the device as well? Can you also please confirm the model of this device? Is there any chance it is the UDP 203?

Please try rebooting your Core machine, networking hardware, and the Oppo device. Once you do this is the experience any different?


Hello it is the oppo udp203. I tried rebooting everything and no changes. I have an ASUS AC1900 router and a MacBook pro computer as the core. My oppo doesn’t show anything in the network page even though it is connected wirelessly to the Asus. I tried configuring roon OS devices and none are found. My MacBook network setup sees only the wireless signal from the ASUS which it is connected to?

Hey @Grant_Grover — Thank you for the additional information.

For next steps, let’s try the following:

  • Can you connect the Oppo using a wired connection to your router and see if the experience improves?

My MacBook network setup sees only the wireless signal from the ASUS which it is connected to?

  • Can you clarify the above a bit for me? Is the MacBook using a WiFi connection? If so, can you try using a wired connection here as well?

Testing both devices with a wired connection will definitely help us narrow down the root cause of this behavior.

Additionally, can you expand on the behavior you’re experiencing a bit more? When you go to Settings > Audio in Roon, does your Oppo device display here, and you’re just not able to play to it? Or are you able to select that device as a zone but playback isn’t working?

Thank you,