Connecting Nucleus to Peachtree nova 300 with USB

Core Machine (Operating system/System info/Roon build number)

Macbook Pro late 2013 OS 10.13.6
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Peachtree nova300, USB

Description Of Issue

I can’t locate the Peachtree nova300 when designating listening zones

Have you enabled the Peachtree in Settings > Audio?

Thanks for the quick response. I don’t see the peechtree listed in my listening zones.

I only see the devices that are connected to the mac directly and then my sony tv listed under the networked devices, nothing for the peachtree that is connected directly to the nucleus

It sounds like what you want to do is covered in this thread:

That is, you want to use your Nucleus as both Core and Endpoint. The Peachtree Nova (an integrated amp with embedded DAC) is not a Roon-ready device. It will not be the endpoint, the Nucleus will be (unless you attach a Roon-ready, networked streaming device to the Nova via USB/coax/RCA/Toslink).

The Peachtree won’t appear under Zones (access via Zone icon next to volume control) if it hasn’t been enabled. Have you checked Settings > Audio as suggested? Please share a screenshot of this.

Also can you confirm the input used on the Nova? I believe it should be USB input B.

I have set my macbook as the core, not the Nucleus. Should I reconfigure this? I am using a USB A from Nucleus to USB B to Peachtree.

If I’m getting this right, your Nucleus is attached via USB to the Nova 300. If that’s correct, yes you should change the core to be the Nucleus. Then you can use the Mac as the remote (or any other Roon enabled device, Ipad, phone, etc.) which will control the Nucleus.

I thought so as well, but I can’t locate the Nucleus as my core when searching for it, only my macbook, which is connected to same network. When I first connected the Nucleus I saw the HDMI port options, but since I designated the Macbook as the core, when I search for a “new” core, I can’t locate the nucleus. It may come down to a network connection problem.

Looks like you need to either
(a) “enable” your Nucleus as an endpoint (in addition to being, possibly, the Core machine)
(b) connect the Nova to your Macbook by USB; “enable” the MacBook as an endpoint; in the Sound system preferences, direct sound output to the Nova

Either way, you need to enable an endpoint that has a connection path to a sound-output device (the Nova). Otherwise, Roon cannot see your Nova. But why would you buy a Nucleus then not use it to run Roon Core?

Obviously, it was my intent to run nucleus as core, but locating it to act as such has become the issue. I will take a fresh look at the network configuration and then try to reboot. Hopefully this will locate the nucleus. Thanks for input.

Disable the Mac as a core. If the Nucleus is new it will need to update and it doesn’t always do so as gracefully as we would like from new. Once fully updated it should present itself to your chosen remote.

I disabled Mac as core, rebooted Nucleus, connected Nucleus to Mac via USB (just to limit problems) and then rebooted Roon App. Still unable to locate Nucleus when searching for core.

Another point. You need to have the peachtree set to the correct USB as the active source, or, it will not be seen.

Hello @Michael_Mosby,

When you disconnect the Peachtree Nova 300 from the Nucleus and then reboot the unit, are you able to see the HDMI zone in the Settings > Audio screen?


Unfortunately, when I have disabled my macbook as the core, I am unable to locate my Nucleus when searching for the core in Roon app so I’m unable to see any zones. I have plugged the Nucleus into my router directly, and still it doesn’t locate, it was on DLAN connection before. I am thinking I may need to use macbook as core again to run diagnostics on nucleus (if that’s a possibility).

Hello @Michael_Mosby,

Running your MacBook as the core should allow you to see the Nucleus zone if it is running.


Hi @Michael_Mosby,

I would also check to make sure that Roon and RAATServer are allowed past your Mac firewall, you can use these instructions from Apple to check this aspect.

I would also make sure that any other antivirus or firewall apps on the Mac are not interfering with your ability to connect to the Nucleus, I have seen McAFee / Norton / Little Snitch cause similar issues in the past.

If the Nucleus is not showing up as the Core, and you have made sure it is powered on and has an IP address, it is likely a firewall somewhere blocking the connection.

I really appreciate everyone’s input, but no matter what I do, I cannot locate the Nucleus. I have dismantled my entire network, to the point it is just my Macbook, a router, and the Nucleus and still no luck. I have checked firewall on Macbook and made sure all Roon apps have permission. I am beginning to believe I may have a lemon here. Is there any means to “reset” the Nucleus somehow even if I can’t locate it? If not, what’s next?

Hi @Michael_Mosby,

Can you please try accessing the Nucleus Web UI and post a screenshot of what you see there?

Also, just to confirm, you have pressed the power button to power the Nucleus on and there is a dim light illuminating from the power area? Are the Ethernet lights on the back blinking?