Connecting Roon to Dropbox

I am unable to connect Roon to Dropbox to use Dropbox as backup for my music library. Roon wants an Authentication Code, but I have no idea how to generate such a code. I cannot find any reference to this in Dropbox either. Am I missing something here? Note: my dropbox account is a normal free account

Thanks for the reply, but this doesn’t work for me. I’ve tried setting up 2-factor authentication on dropbox and using the 6-digit code (tried both SMS and google authentication app) in Roon, but nothing happens when I enter the code into Roon…

Roon uses Dropbox to store backups of your database, but this is not a backup of your media file.

However, when you click Connect in Roon a web page should open in your default browser with the following:

Click Allow and you’re provided with a code. Copy this and paste into Roon:

Thank you.

This makes sense, but when I click the links presented by Roon, nothing happens: Is this a MS Windows issue? None of the “links” presented by Roon works when I click on them

1 Like

For what it’s worth have 16gigs space in my Dropbox and roon tool just about all of it. If you are on a free plan I recommend doing something else

Yes, I’m on a free plan with Dropbox. Sorry about the confusion, but I’m merely trying to set up dropbox as a backup for my music library,

Sorry, I don’t use Windows, but I would expect the browser to be launched when clicking on the Connect button in Roon.

I’m moving this thread to #support.

Hi @Jakob_Carlsen,

Do you have a browser open already on this machine? Or a default browser set in Windows? When you go through this process the page should open automatically in the browser. What browsers do you have installed?

Hi @dylan,

I have quite a few browsers installed, but Chrome should be set as default browser. But thanks for the tip, I’ll check that chrome still is default. Ihave experienced some problems with other links.


Hi @Jakob_Carlsen,

Thanks for the update! Definitely make sure Chrome is set as default and let us know how it goes. If you have any other questions or issues please let us know.


It didn’t work with Chrome as default browser, but I was able to get around it by setting Edge as default browser, clicking the link, and the copying the URL into Chrome. All set up now. Thank you @dylan, @Martin_Webster, @Gareth_Irwin and @Jim_F!


Hi @Jakob_Carlsen,

I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.