Connecting roon to my Lampizator DAC


I just installed a Bricasti M5 streamer and I am trying to connect it to my Lampizator BIG 7 DAC.

Roon can’t find that device.

Thus far a can play tidal through roon on my iPhone and Mac, but I’m getting no signal to my DAC.

I would greatly appreciate any help on how to accomplish this. Apparently lampizator is not one of the partners with Roon.


Hi Tom,

I’ve converted your post from a private message to a thread in the Support section so Roon staff in @support can assist.

Can you describe your system, including the hardware on which your Roon Core is running ?

The Bricasti m5 is Roon Ready, so one way of connecting things would be to run Ethernet from your Core to the Bricasti and then connect an output from the Bricasti to the Lampizator DAC input you prefer. Your Core should then see the Bricasti as a Zone and you should hear music through the DAC after selecting the input connected to the Bricasti.

HI Andy,

Thanks so much for replying.

Currently I have a Cat 7 ethernet cable from my modem connected to the Bricasti. I’m not sure how to connect another ethernet cable.

Are you suggesting I connect an ethernet cable from my core which would be the Mac computer directly to the Bricasti and then proceed from there.


No that’s not necessary. Provided both your Mac and the Bricasti are connected to the modem/router then Roon should see the Bricasti.

If you can post a screenshot of Settings/Audio then we can check what Roon can see.

You seem to be typing into a text box. There is no need to do that. Ordinary text is fine.

so a screen shot of settings in/audio show in roon?

According to your screen pic, you are playing to the Bricasti as connected via the MAC. Not via Ethernet. Try Choosing the M5 as the output zone and see if that changes things.
You can change output zones, by clicking on the volume icon at the bottom, click the Switch Zones and then choose teh M5

1 Like

Hi Daniel,

I did as you suggested but there is still not connection to the DAC from the M5 zone either.

I did as you suggested but there is still not connection to the DAC from the M5 zone either.

Roon won’t show such a connection.

How is your DAC actually connected to the Bricasti ?

How are you connecting the M5 to the Lampi? And are you sure you have that set correctly on the M5 as its output.

It’s connected via an AES/EBU digital cable.

I have no clue what an ITS output is. How would I go about doing that.

sorry the captialization threw you - it’s - as in it’s output to the Lampi

there is absolutely nothing anywhere that shows lampizator.

I was sold this unit as a plug and play…LOL not so

there is a green op amp in the lamp that glows solid green when the dac is connected to a source.

currently it is only blinking green thus not connected

Can you confirm you do not have a usb cable plugged into the Bricasti from your Mac? Having a usb connection can/will disable the AES output, if you have then remove it and reboot the Bricasti.

I have nothing plugged from my mac to the bricasti other than the ethernet cable coming directly from the modem.

I can get tidal playing through roon on my iPhone and computer but no signal to the dac which is connected to the bricasti via the ads cable

If you have the Lampizator connected via AES/EBU then roon can’t tell what dac it its as far as I know.