Connecting to NAS on Macbook Pro w/M2 Chip

Roon Core Machine

14" M2 Pro Apple MacBook: 10 Core CPU/16 Core GPUI/n3XTB3 I 16GB I 1TB

Networking Gear & Setup Details

Synology DS213 afp://MusicNAS._afpovertcp._tcp.local/MusicNAS

Connected Audio Devices

Number of Tracks in Library

10,912 Tracks in the iTunes Library stored on the NAS

Description of Issue

I downloaded Roon for Mac M1 (you don’t have M2 button) and when I try to change the AFP to SMB on my NAS as suggested in the FAQ, the screens I get look nothing like the ones you use to give the examples.

Qobuz interacts fine, but I cannot interact with my NAS.

I would like to be able to use Roon for all my digital music.

Welcome to the Roon community, @Roger_Miller1.

It’d be really helpful if you could share some screenshots of what you’re seeing.

Hi Martin,

The more I try to figure this out, the more confused I become.

Here are some basic screen shots from my system.

It would be helpful if someone could talk me through this.



You need to enable Samba (SMB) on your NAS, since Roon cannot see an AFP share. You’ll need to refer to the manufacturer’s instructions to do this, unless a Synology user can assist.

Once you’ve done this, you can add the SMB share to Roon.

From Control Panel, File Services. Enable SMB

1 Like

Evidently, The architecture on the MacBook Pro 14" w/M2 chip is different.

I have followed the intructions for switching to SMB and the import from NAS to Roon instructions and something is still not working.

Two things:

You need to use the correct form of the Network share address, I think. that would be

smb://MusicNAS/<Folder share> assuming that the hostname of your NAS is MusicNAS.

You also appear to have all your music tracks listed under the root folder of your NAS share. That’s going to present Roon with difficulty in identifying albums and tracks. I suggest that you create a folder share “Music” on your NAS, and then put tracks into an <album name folder>/<tracks> structure to give Roon a helping hand.

Adding to @Geoff_Coupe observations is that I was using the Synology Control Panel, and log there into the app that is managing the Synology NAS. Then go to control panel and enable SMB. I have not tried to use OsX to manage Synology from Sys prefs (I do not know if you can do that, from sys pref you manage only the local drives)

Screenshot 2023-02-15 at 17.50.07

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.