Connecting to Roon Arc

Roon Server Machine

CPU AMD Ryzen 9 5900X 12-Core Processor 3.70 GHz
RAM 64 GB

Networking Gear & Setup Details

I use an Orbi Mesh wireless router RBR850. I do not use a VPN

Connected Audio Devices

Connected audio devices from my computer is a USB DAC RME ADI-2 DAC to an SMSL amp to bookshelf speakers

Number of Tracks in Library

8200t tracks

Description of Issue

I am trying to connect to Roon Arc and have gone through the troubleshooting section. I am still unable to connect. UPnP is enabled. I have tried different listening Port numbers. This is the error I still get. Roon Server is on my PC.

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“47.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}
}

Try turning OFF UPNP in the router and setting up the port forward (TCP) manually.

I did try this, however I still got an error message, this time saying UPNP Not Found. I double checked the Port Forwarding and even tried a few different listening ports (ensuring I added it to my router port forwarding as well) and the same errors were had. I turned UPNP back on and the same thing as I originally posted happened.

This is very frustrating!

Hi @Mark_Ishak,

There are three possible culprits blocking port forwarding based on the information above:

  1. Your internet service provider has implemented carrier-grade network address translation, so your IPv4 public address isn’t passing to ARC.

Who is your ISP?

  1. You have a second router in your network that is still active.

Is there any additional network hardware in your setup?

  1. Lastly, it’s possible that antivirus software or a network firewall on the RoonServer machine itself is preventing the port forward.

Thank you Connor for your response.

My ISP is Spectrum

I unplugged all wifi extenders thinking this may he it, but that did not work.

I also disabled my firewall and antivirus temporarily to retry, however again it did not work.

It might be the ISP issue with spectrum. Is this fixable?

Hi @Mark_Ishak,

Thank you for the update. What’s the current error diagnostic message in Roon → Settings → ARC?

The original message indicated that UPnP was installed on the router but for some reason unavailable to RoonServer. Usually, this points to a firewall or security apparatus on the network or RoonServer machine. However, since the port forwarding still fails with these disabled, we’ll need to check the current diagnostic to pinpoint the remaining blockage.

Additionally, you can skip a step and reach out to Spectrum directly to inquire whether they have CG-NAT on your account tier and whether a dedicated public IP address is available. They may also offer IPv6, which can function in certain implementations.

We’ll be here to assist. Thank you!

{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“96.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.1.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">501ActionFailed</s:Fault></s:Body></s:Envelope>”}
}

So I did get it to work! (silly me, I missed one of the firewalls).
How do I get this to work with my firewalls back up?

Thank you!

Hi @Mark_Ishak ,

Thanks for letting us know of this update. Which type of firewall did you disable to resolve the issue?