Connection Failed Linux 4.19

@support

Trying to get version 1.5(version 363) Server up and running on my Manjaro box which is running kernel 4.19. Appears the server can be seen but just cant connect. Much like I have read in other threads.

So here is what I have tried so far
Yes, roon is running on my Linux box.
Yes, everything is on the same domain and the same subnet
Have tried turning off the firewall on my router, TP-Link ARCHER-C7 v2 running dd-wrt.
Tried forwarding the ports on the router. Having no luck.
Curiously, Can run core server on my macbook and have no issues connecting via the network.
Which is making me think its something on the Linux box. Is there a config file where I can check if the server is able to accept connections?
Anyone got any thoughts

***** Finally****
Went back and uninstalled Roon, Deleted any remaining folders. Rebooted, reinstalled
Bingo!!
Hope this helps someone

Update
Server showed ready. Clicked to connect. logged in and now back to where I was.
Failed connection

Final update
Uninstalled everything again. Used the AUR installer this time around.
SUCCESS!!

Great news, enjoy.

Back to square one.
came home from work and couldnt connect
get this when I run status -Thoughts?

roonserver.service - RoonServer
   Loaded: loaded (/usr/lib/systemd/system/roonserver.service; enabled; vendor preset: disabled)
   Active: active (running) since Wed 2018-12-26 19:33:20 EST; 41s ago
 Main PID: 740 (start.sh)
    Tasks: 59 (limit: 4915)
   Memory: 332.3M
   CGroup: /system.slice/roonserver.service
           ├─ 740 /bin/bash /opt/RoonServer/start.sh
           ├─ 749 /opt/RoonServer/RoonMono/bin/RoonServer --debug --gc=sgen --server RoonServer.exe
           ├─2867 /opt/RoonServer/RoonMono/bin/RoonAppliance --debug --gc=sgen --server RoonAppliance.exe -watchdogport=44597
           ├─2869 /opt/RoonServer/Server/processreaper 2867
           └─2939 /opt/RoonServer/RoonMono/bin/RAATServer --debug --gc=sgen --server RAATServer.exe

Dec 26 19:33:50 HTPC start.sh[740]: Got a SIGABRT while executing native code. This usually indicates
Dec 26 19:33:50 HTPC start.sh[740]: a fatal error in the mono runtime or one of the native libraries
Dec 26 19:33:50 HTPC start.sh[740]: used by your application.
Dec 26 19:33:50 HTPC start.sh[740]: =================================================================
Dec 26 19:33:51 HTPC start.sh[740]: Error
Dec 26 19:33:53 HTPC start.sh[740]: Initializing
Dec 26 19:33:53 HTPC start.sh[740]: Started
Dec 26 19:33:54 HTPC start.sh[740]: aac_fixed decoder found, checking libavcodec version...
Dec 26 19:33:54 HTPC start.sh[740]: has mp3float: 1, aac_fixed: 1
Dec 26 19:33:57 HTPC start.sh[740]: Running
[htpc@HTPC ~]$

@support
No change,
Updated to Kernel 4.20 and no luck.

One thing I did notice is I can get the server up and running, Shows ready to connect. I check server status and everything is a go. Until I try and login with my user id and password. That appears to be when it crashes.

Thanks in advance for any suggestions

Hello @Darrin_Reiss,

Thanks for contacting us regarding this issue. Hmm, it seems that you might not have the correct dependencies installed for that build, can you please try running these commands and let me know if that helps?

sudo apt-get install ffmpeg
sudo apt-get install libav-tools
sudo apt-get install cifs-utils

If those commands don’t help I will try to assist with what I can but ultimately this may end up as a question for the QA team and with the holiday season some staff is out, but hopefully we can pinpoint the issue before needing to reach out to them. Please let me know your findings when possible.

Thanks,
Noris

Noris
I thought the same thing but I have all those installed. Thinking one might be corrupt. I re-installed them this morning but not luck.

No worries on the time frame. Loved it for the 12 hours that it was up and running. We’ll figure it out. I’ll have a bit more time tonight to work on it.

Hello @Darrin_Reiss,

I have spoke to the QA team regarding your issue. They agree that it appears that you’re missing some dependencies here. We have enabled diagnostics mode on your account and we are seeing the following trace in your logs:

 12/27 08:53:16 Warn: [broker/accounts] error loading account data: System.Security.Cryptography.CryptographicException: Padding is invalid and cannot be removed.
  at System.Security.Cryptography.RijndaelManagedTransform.DecryptData (System.Byte[] inputBuffer, System.Int32 inputOffset, System.Int32 inputCount, System.Byte[]& outputBuffer, System.Int32 outputOffset, System.Security.Cryptography.PaddingMode paddingMode, System.Boolean fLast) [0x0053f] in <370a0c27f4b74d1a81431037df6d75bf>:0 
  at System.Security.Cryptography.RijndaelManagedTransform.TransformFinalBlock (System.Byte[] inputBuffer, System.Int32 inputOffset, System.Int32 inputCount) [0x000a3] in <370a0c27f4b74d1a81431037df6d75bf>:0 
  at System.Security.Cryptography.CryptoStream.FlushFinalBlock () [0x00018] in <370a0c27f4b74d1a81431037df6d75bf>:0 
  at System.Security.Cryptography.CryptoStream.Dispose (System.Boolean disposing) [0x0000b] in <370a0c27f4b74d1a81431037df6d75bf>:0 
  at System.IO.Stream.Close () [0x00000] in <370a0c27f4b74d1a81431037df6d75bf>:0 
  at System.IO.Stream.Dispose () [0x00000] in <370a0c27f4b74d1a81431037df6d75bf>:0 
  at Sooloos.EncryptedAccountHelper.Decrypt (System.Byte[] blob) [0x00070] in <6a0c4117101246878611d7ca74986e58>:0 
  at Sooloos.Broker.Accounts._Load () [0x0000b] in <bbda6a553eb048f1b5c5c7aa2e58a1a5>:0 
12/27 08:53:16 Trace: [broker/accounts] Data updated. AccountStatus=NoAccountConfigured MachineStatus=NeedsAccount UserId=<none>

Would you by any chance have any ideas of possible missing dependencies on your machine?
I am also not sure if you have Mono properly installed on that machine, it could be worth to double check and possibly re-install it from the Mono Project Site. Please let me know if that helps.

Thanks,
Noris

Hi Noris
No idea but reinstalled mono again and then ran check.sh Results below

[htpc@HTPC RoonServer]$ ./check.sh

Checking to see if RoonServer can run on this machine

Checking for Binary Compatibility                            [   OK   ]
Checking for ALSA Libraries                                  [   OK   ]
Checking for ffmpeg or avconv                                [   OK   ]
Checking for the mount.cifs command                          [   OK   ]
Testing ulimit -n 8192                                       [   OK   ]

STATUS: SUCCESS

[htpc@HTPC RoonServer]$

Thinking this may be drive related. The boot drive is just about full and other programs appear to be having issues as well. Have a new drive coming Saturday. Hopefully, can get it installed this weekend and crossing my fingers that this puts this issue to rest.

No issues installing on two other laptops. Unfortunately, I dont want the core on either of those on a perm basis.

1 Like

Last update.
So the new drive arrived this morning. Actually took the gamble did a clean install of Manjaro 18.
Installed Roonserver first thing. Success! Came right online and was able to set everything up.

Then… It took about six hours before it started to act up again. Started throwing transport errors this time. So I rebooted. That was a MISTAKE…
Now were right back to where I was originally. uninstalled, rebooted. reinstalled. Same issue.

Unfortunately, I’m not in a place where I can dedicate any more time trying to get this operational on my system. That said, when it was working. WOW. loved it. Shut up and take my money already.
Noris, thanks for trying to help it was appreciated.