Connection Failure RoPiee 254 and Roon 1.6 (Build 401)

(Kristian Næss) #1

Today I installed a RoPieee on a RPi 3B+ with the official 7" touch display. I used the latest build 254. No luck. Just connection errors all afternoon. I cannot for the life of me find any extensions in Roon even though the guides I have read indicates that I need to enable the extensions for RoPieee in Roon. I have no DAC or HAT on the RPi, it is just ment to be a “remote control”. I can see the RoPieee in the About section of Roon. It shows ut with the right IP. I had no luck with it connected by cable or by Wifi. I even flashed it a couple of times and I even reinstalled the Roon Server.
I do not know what to do except hit “send feedback” and go to bed :slight_smile:
ID: 318724ed2d2cc0ce

BR
Kristian

(Henry) #2

Menu (three lines, top left of Roon display), Settings (scroll down), Extensions. Enable Ropieee extension from there.

(Nathan Wilkes) #3

Make sure you type the associated zone you want to control “correctly”. Perhaps upload a screenshot of your RoPieee config and your zones in Roon?

Also, where are you seeing the errors? On the display? What do they say?

(Mr Fix It ) #4

I would also disable any firewall in case its an issue (windows especially)

Can you access the Ropieee Web UI? and I would stick with LAN connection if I were you…for now at least.

I run 3 with displays and 2 are display only and work fine but the zone names must be identical…cut and paste is your friend here

In my case this is XMC-1 LOUNGE USB and the actual XMC is connected to a different RPi with Ropieee as the USB cable is not long enough for where I want the display.

(Kristian Næss) #5

Thanks for the replies :slight_smile:

I can access the RoPieee UI and configure it just fine.

The screenshots looks very much exactly like what I have configured, except for the one where the extensions in Roon are. I do not fint those on my setup. I have all meny options except “Exensions” in my settings meny in Roon.

My zone name is “digione”. I canged it to all lower case and no spaces just to be able to type it correctly.

I have the core running on Ubuntu 18.04 LTS. I have no Windows GUI anywhere. I am running all Android (mobile and pads). I already have a “Allo DigiOne Signature” that is working fine with my setup along with several other none RPi devices.

I might install a Windows based Roon Core just to try that out as well, but for nowm it is off to work.

BR
Kristian

(Mr Fix It ) #6

I wonder if its a Core on Ubuntu issue…Tho I have Rock as a Core also and it works fine for this function.

(Harry ten Berge) #7

The logs look fine. But I also see that it looks like you did not enabled the extension on Roon Core.

I do remember though that on some older versions of the apps you could not find the extensions.

As you’re running Ubuntu I assume you know you’re way around Linux. In that case it might be a quick check to install the Wine version (I build something for that: https://github.com/RoPieee/roon-on-wine) to see if you can enable the extension from there.

But in general I would see: no need to reinstall your core or pi, because on that side everything looks ok.

(Mr Fix It ) #8

Assume it’s really 253 not 254 as I can’t seem to find any update to 254

(Henry) #9

Are you using full resolution versions on Android. If the Roon app sees a lower resolution screen it delivers the simple version of the GUI. This misses certain options off and might explain the missing extensions option.

(Kristian Næss) #10

Version is 254 according to the WEB GUI:

(Mr Fix It ) #11

Hmmm I better check again…the website only posted 253 also.

(Kristian Næss) #12

I know, but the GUI says sonething else :expressionless: Have I gotten a Beta version? Will reflash with an older version in about 10-15 minutes.

BTW: Installed Roon Server on a Windows 10 Laptop with the firewall disable. No luck, still cannot enable extensions since it is still not visible under settings both on my phone (Samsung S9+) or on my pad (Huawei).

(Mr Fix It ) #13

I just rebooted to update all my units again and no changes - maybe its beta indeed.

(Harry ten Berge) #14

You need to access Roon from a windows machine, not from a mobile device.

1 Like
(Harry ten Berge) #15

Yes it seems you’re on the beta channel (look in the advanced tab). But for now that’s not important.
There’s nothing wrong with RoPieee, you just need to have access to Roon UI other then a phone so you can enable the extension.

(Kristian Næss) #16

Extensions showed up on the Windows machine. Enabled it now, so I expect it to work pretty soon.

(Kristian Næss) #17

And then it just worked. It is so nice to get the final piece of the puzzle. Windows installion of Roon “Remote” did the trick.

The remote looks really good. Keep up the good work, there is a small donation on its way.

(Nathan Wilkes) #18

I never noticed this limitation. I always use an iPad.I’ll update the guide in the next week or so.

1 Like
(Harry ten Berge) #19

I think this is particularly on Android devices only.

(Nathan Wilkes) #20

Done. (10 characters.)

2 Likes