Connection issue since network update

Hi all! I hope someone can help me get back into listening business!

Core Machine (Operating system/System info/Roon build number)

Synology NAS 418 Play (Has worked perfectly during trial)
Core installed on USB drive
Library stored on 4TB drive
Songs: 3700

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Previous situation: Nas connected by ethernet to Netgear PROsafe GS105 4 port switch, which was in turn connected to my internet router. BS Powernode2 was also connected to that same switch and a Node2 was connected to the internet router. All wired and the system worked perfectly.

New situation: The wifi of my internet modem was disabled and replaced by a TP-Link Deco M5 mesh network. Wired to this network is a TP-link SE108E manageable 8 port switch. (to replace the internet router) So the NAS and Powernode2 are both still connected to the same switch, which is now connected to the new TP-Link switch. All still wired. The NAS can still be accessed by any device in the network, except for the Roon app somehow.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Powernode2 - Wired
Node2 - Wired
Pulse Flex 2i - Wifi

Description Of Issue

When trying to log into any of the controllers (iPhone, PC or iMac) the app tells me there is a error and that I need to check my internet connection. I can’t find anything wrong on my connections though so I think there is some issue with DNS/IP or something like that which I do not really understand.
The Flow control of the port where the switch to the NAS is on is enabled.
What can I do?

Hi @Jkav,

As noted in our Networking Guide, managed switches often require some advanced configuration to work properly. Ultimately we need to make sure that multicast traffic is able to properly flow on the network uninterrupted in order for communication between your Core and the remotes to work.

Another thing to check here — Did your Synology previously have a static IP? If so, was that IP changed when the new network was configured? We need to make sure that the Synology is still on the same IP range as the other devices.

Can you access the Synology outside of Roon, from either Finder or File Explorer?

Hi Dylan, thnx for helping out!

The Synology does have a reserved IP address but is still on the same IP range. It is also reflected on the Roon controller app correctly. (On the page where I can choose to connect to a core in my network, it’s the only one available) I can access the NAS library as usual using the Bluesound app or via Plex or any computer in my network without issues.

I also have the multicast setting enabled on the Switch but sadly this does not help. I think I am still not understanding something about the network settings. Don’t know what though :sweat_smile:

Hey, I found the log for today’s attempts and it shows the following at moments when I try to log in:

11/25 16:29:02 Info: [stats] 2804mb Virtual, 383mb Physical, 816mb Managed, 0 Handles, 28 Threads
11/25 16:29:08 Info: [brokerserver] Client disconnected:
11/25 16:29:17 Info: [stats] 2804mb Virtual, 383mb Physical, 816mb Managed, 0 Handles, 27 Threads
11/25 16:29:27 Info: [brokerserver] Client connected:
11/25 16:29:27 Trace: [SOOD] Adding User IP
11/25 16:29:27 Trace: SENT NONFINAL DistributedBroker.ConnectResponse={ BrokerId=aefd161c-68e1-49dc-85bf-58da90a7419b BrokerName='Synology' }
11/25 16:29:27 Trace: SENT NONFINAL DistributedBroker.UpdatesChangedResponse={ IsSupported=True WasJustUpdated=False Status='Error' HasChangeLog=False CurrentVersion={ MachineValue=100700667 DisplayValue='1.7 (build 667) stable' Branch='stable' } }
11/25 16:29:32 Info: [stats] 2804mb Virtual, 384mb Physical, 816mb Managed, 0 Handles, 28 Threads
11/25 16:29:32 Trace: [fiveaccountserver] POST
11/25 16:29:32 Trace: [fiveaccountserver] BODY email=XXXXX@XX&password=<<<PASSWORD>>>
11/25 16:29:32 Trace: [broker/accounts] Data updated. AccountStatus=NoAccountConfigured MachineStatus=NeedsAccount UserId=<none>
11/25 16:29:47 Info: [stats] 2804mb Virtual, 384mb Physical, 816mb Managed, 0 Handles, 28 Threads
11/25 16:29:52 Warn: Error in web request NetworkError (Error: NameResolutionFailure)
11/25 16:30:02 Info: [stats] 2804mb Virtual, 384mb Physical, 816mb Managed, 0 Handles, 28 Threads

Does this show the issue? Or would you need more info?

Hi @Jkav,

It looks like you’re running into a DNS error when trying to connect to our account servers.

Do you know what DNS your network is using currently? Can you try using Google DNS or Cloudflare DNS?

if you have a windows machine type the following in powershell and post the results, this will test the name resolution and the connection is not being blocked

test-netconnection -computername -port 443

Hi Dylan, I do. I can see it in the IP settings of the Deco M5 router. Do I have to check it with something?
Sorry I am a complete idiot when it comes to networking.

Thnx for the response, I think I entered it wrong:

PS C:\Users\Justin> test-netconnection -HP-Justin -port 443

WHich got me this:
Test-NetConnection : A parameter cannot be found that matches parameter name ‘HP-Justin’.
At line:1 char:20

  • test-netconnection -HP-Justin -port 443
  •                ~~~~~~~~~~
    • CategoryInfo : InvalidArgument: (:slight_smile: [Test-NetConnection], ParameterBindingException
    • FullyQualifiedErrorId : NamedParameterNotFound,Test-NetConnection

The smiley popped up there haha, was obviously not in the Powershell result. Was ( : )

you need to type -computername rather than your “computer name”

I.e type what I posted word for word.

:man_facepalming: That seems to work. I then get the following:

ComputerName :
RemoteAddress :
RemotePort : 443
InterfaceAlias : WiFi
SourceAddress :
TcpTestSucceeded : True

Looking at this though, the source address, which I assume is meant to be the NAS according to the roon server, is incorrect. The actual IP address from the NAS ends with 101. Is that what is causing the problem? Do I simply appoint that IP address to the NAS to fix that?

EDIT: Guess not, tried and failed

No that’s fine, that is only checking that your network can resolve the Roon name to an IP address and that it can connect.

I see that Google DNS and Cloudflare are extra services, I’d like to note that everything worked perfectly before during the trial. I’m sure the issue is with the network settings somewhere. The DNS addresses are those of my Internet provider. To be sure I double checked them and they match.

I did try the Google Public DNS but that did not solve the issue unfortunately. Is there anything else I can do?

YESS! Fixed it! DNS settings on my server did not match those set in my router. At least that is what I figure after changing that. Thnx for the help!

1 Like

Happy to see you’re up and running, @Jkav! Please feel free to reach out if you ever have any other questions or concerns.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.