Connection issues / pausing between tracks / remote not connecting / LSX speaker connectivity issue

Core Machine (Operating system/System info/Roon build number)

Mac OS 10.14.6 - MacBook Air 13" 2018 - Rune Build 1.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi Router RAC2V1K by Spectrum / WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

KEF LSX (wifi)

Description Of Issue

I have a few issues that I am hoping to resolve:

  1. When first connecting to the LSX speakers, the LSX will show as a zone through AirPlay, but not as a Roon Tested device directly with the speakers. However, if I play music through the connection via AirPlay, even if I pause it immediately after, the ‘Roon Tested’ pathway to the speaker mysteriously shows up to the party and can be selected / connected. I would obviously like to be able to just select them initially. What’s goin on here?

  2. Sometimes, when selecting a new track from another album, or when skipping to the next track in a playlist, music does not play even though it is showing as :01 seconds into the song and play is enabled. If I pause and repress play, the music will begin. I have noticed this usually occurs when there is a bit rate change between songs. I understand there is potentially a delay as the speakers switch to the different bit rate, which is fine, but the music doesn’t restart unless I do it manually, which is not.

  3. My phone (Google Pixel 4XL) will only sporadically connect with the Roon Core (my laptop) - most of the time it just says ‘Looking for your Roon Core’ but rarely connects.

Hoping to resolve these issues asap so I can be 100% enthusiastic about this otherwise fantastic software!!

Thank you very much,


Hello @Derek_McCarty,

Welcome to the forum! For issues 1/2, is there any change in behavior if you try to factory reset the KEF speakers? Instructions can be found in section B2:

This usually indicates a multicast issue somewhere along the line. Multicast is a protocol that Roon uses for Core/Device discovery and I suspect that your router is not passing multicast traffic properly. There are a few things you can try here:

  1. I would look for any IGMP Snooping/Proxying settings on your router’s configuration page and try toggling these settings.

  2. You can try to connect via the Multicast broadcast ID to see if you’re able to connect to the Core that way, you can do this by clicking on the “Help” button that appears on the Choose Your Core screen and setting the IP of or the IP of the Core directly.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.