Connection issues

Before the last update I was so content with Roon connecting w/o any hitches OR delay so I could control my music via iPhone (6S). I had more or less given up on JR Remote failing to connect and Roon came like a rescuer.
My library resides on a Mac Mini all connected to an Airport network (Airport Extreme/Airport Express 4th gen) and ALL running the absolutely latest in OS. Now it always takes time before connection and often connection fails altogether. Something’s been screwed up in the latest update that’s for sure. I’ve checked firewall and incoming connection is allowed for RAATServer, RoonAppliance and Roon Server.

Suggest you try first turning OFF the firewall completely and see if that works.

Hi @Jonte_Takman ---- Thank you for the report and sharing your observations with us, both are appreciated!

Moving forward, I would suggest giving the following a go to see if we can trigger a change in behavior here:

  1. I see based on your report that you’ve confirmed that a security exception is in place to allow both Roon and RAATServer to communicate with your network :clap: In the interest of being complete, I would agree with @wizardofoz 's suggestiong and try temporarily disabling the firewall completely just to confirm that things do not function differently with the firewall down.

  2. Have you tried power cycling your equipment yet? This would include your Roon core, Roon remote, your endpoints, and any networking hardware (i.e routers, switches, repeaters, extenders, PoE, etc).

  3. Have you tried reinstalling the application on the iPhone (6S) since experiencing this behavior?


With FW off connection is IMMEDIATE!!! I have restarted the mac (holding the Roon software) and even the network (although not simultaneously). Not reinstalled the ios app.

1 Like

You may want to look into this anyway. Accessing the library through iOS app has degraded over time since last fix. I erased app and did everything as recommended. Now it’s hit or miss again. Went on to shut down firewall altogether and now it’s fine again. But BEFORE last update I could have it on: NO PROBLEMO!

The last update added TCP as the primary protocol so this could be where the firewall is now blocking but perhaps was passing UDP before…Just a thought.

Hi @Jonte_Takman ----- Thank you for the follow up, good to hear from you!

Moving forward, can you please provide screenshots highlighting the security exception(s) you’ve made in OSX for both RoonServer and RAATServer?


Here you go:

Hi @Jonte_Takman ----- Thank you for the follow up and providing the requested screenshot, both are appreciated!

Moving forward, I would like to grab a set of logs from you and will be contacting you via PM with instructions momentarily.