Connection of Pro-Ject Stream Box S2 Ultra Roon Ready

@support,

I have downloaded Roon to my PC but then I can`t connect to my new Pro-Ject Stream Box S2 Ultra

In Roon I’m trying to get the program to find the new device without success.

Yes I have put the Roon Ready button in the streamer to ON.

Thanks for reaching out, @Sven_Olof_Ersmarker!

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

If it’s enabled, can you try temporarily disabling any firewall on the Core machine? Once you do this is there any change?

Are other endpoints being found by Roon?

Thanks!

1 Like

Hello,

old thread but I’ve same problem. Streambox fully present with working IP address as shown in a network scanner, but Roon doesn’t see it.

Then there’s this easy trick: push the USB/PC bypass button on the StreamBox to ON, and then push it again to OFF, now Roon sees the Streambox as an output device immediately.
This little ON-OFF cycle seems to wake up ROON’s attention.

If this could be addressed by Roon in collaboration with Pro-Ject, that would be fine with many thanks in advance.

Greetings, J.

I’ve come one step closer as to why ROON does not see the Pro-ject stream box S2 Ultra as an output device. The good news is, when you never change DAC then this will not be a problem, then Roon always notifies the Streambox right away, at least so far and kocking wood.

But when you turn OFF the Streambox, change DAC, start it up again, then Roon does not see the Streambox. All the while the Streambox is active on the network as seen on a network scanning.

My trick to push the USB/PC button ON and OFF seems to make Roon notifying the Streambox as suggested.

The real deal imho lies in the fact that if you changed DAC (no identical dac) on the Streambox during a power-off-state, then powering up again, it does not automatically change itself towards having a new DAC connected. If you start up the mobile app from Pro-ject (if the connection fails between this app and Streambox then just manually choose the right IP that a network scanning tells you, I use FIRST ROW network scanner app) and goto settings/playback-options, then you will see in AUDIO OUTPUT that it is still on the former DAC, not the one you newly connected. Tap on the list to see immediately the new DAC, SAVE and it says CONFIGURATION UPDATED, PLAYER SUCCESSFULLY RESTARTED. From now on Roon will detect the Streambox without a problem.
I’ve tried other SAVE actions on the Streambox settings to see if those also work, but no, it is only the re-atributing towards the new DAC that works, that and the USB/PC on-off trick. So far…

Resume: with the Streambox last-remembered DAC and then switched back ON with another DAC, it needs to be updated manually (in the pro-ject app or also perhaps on a web-page based UI but did’t check the latter out) to get it co-axed with the newly connected DAC. If not, then Roon does not see the Streambox on the network.

What happens if you change DAC without powering OFF the Straembox?
Roon keeps seeing the Streambox, no problem in this case, but because you changed DAC in a Streambox ON state, now you cannot update the Streambox towards having a new DAC, the list to choose from will refuse you to see a new DAC. Is that a problem? I don’t know. But usually when I change DAC it is on another loaction so a power OFF state comes in between anyway.

I hope this little issue can be solved with an update, I might post it towards Pro-ject but Roon team may also check this out and apply some gentle pressure :blush: in contact with Pro-ject? I had some questions posted (not related to this matter) to Pro-ject but got only a question-confirmation back, too bad.

There might be other reasons out there for Roon to not see Streambox, but only found the change-DAC issue (during a power off state) so far and hopefully stays that way.

Thanks for your attention, with greetings.

Posted this to Pro-ject, got a swift reply they’re going to ivestigate.

Hey @Jurgen_S,

Thanks a lot for taking that step. I wanted to follow up and see if you’ve heard back from Pro-Ject?

Hi @rebeka ,
Except for that notice that they are going to look into it, there’s no further news.

Has the behavior of the Pro-Ject Sream Box S2 Ultra and Roon improved at all, or is it just the same?

We’d love to do anything we can to help on our end :pray:

Hi @rebeka ,
Thank you for engaging in this.
My Streambox S2 ultra has most recent update


This has not solved the issue yet.

I hope they don’t care me citing part of the reply:

It should be very easy to test this here ourselves. Roon is actually very detail oriented when testing all of this, but the handling of connecting new DACs is obviously not Roon specific, so testing this could have been missed indeed.

So Roon can’t do much about it, seems a pro-ject issue, but Roon indicates the effects by not finding the device. But once you know how to co-ax the Streambox to a different connected DAC then it’s not a real problem.

A pro-ject software update might automate the dac change handling for more convenience, but for the moment one needs to acknowledge a DAC change manually in de pro-ject settings each time after power ON.

With regards.

1 Like