Connection problem with Meridian ID41

Core Machine (Operating system/System info/Roon build number)
PC, Windows 8. Running Roon as both Core and Control.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
PC on Ethernet.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Meridian 808v6 ID41 connected with LAN cable.

The system comprises router > switch > PC > switch > ID41 on Meridian 808v6 > DSPs.

Description Of Issue
The ID41 connection on my Meridian 808v6 is not working with Roon. It will play through the USB connection with no problem. However, when trying to play through the ID41 connection the 808 displays “no lock”.

In the Meridian configuration program I installed a phantom MC200 so as to enable the ID41. I thought that the Roon protocol would enable this connection to work. Please advise if I have made a setup mistake or omission.

Roon recognises the device in Zones and shows music playing. It also recognises it as “Meridian 800 series input audio”.

[I previously posted this question in a different section but perhaps this is the correct place.]

You need to enable the ID41 zone in Roon and not the USB zone. Can you confirm you are playing music to the ID41 zone ?

As long as you have a configuration in the 808 that shows ID41 nas Roon is aiming at that it is about all you need to do

Thanks Nick.
Yes, the ID41 Zone is enabled. It shows music is playing to that Zone when I select it but the 808 displays “no lock”.

Can you ping the ID41? Is it visible On the network?

What source on your 808 does the Aux/Sooloos input correspond to? And what is its comms setting? No lock suggests that perhaps it’s USB or SPDIF rather than the ID41.

Hello Nick
I don’t know how to ping the ID41. As for visibility, it shows in the configuration program. Is that what you mean?

Hello Joel
I set up a phantom MC 200 for ID41 input. It shows an ID41 input on the 808 in the configuration program.

Hi Howard, can you post your Meridian config file to me in a private message?

FYI, I’m not in Roon Support, but I do know Meridian…

Thanks Joel. I have replied via the Meridian HH private message service.

Does your ID41 have an ip address if you look at your home network ? Check your router or use an app like FING. Just rule out that you haven’t got a network issue first.

Joel will quickly be able to review your config file too.

All sorted and sounding awesome ?

My thanks to Nick for advice and support and especially to Joel who kindly corrected some errors on my config. file. He has bravely persevered but I have to conclude that this is a Meridian problem and not a Roon problem. I shall contact Meridian. [I did also try a different cable but that did not solve the problem]

Since last posting I have had further help from Joel and very good help from Richard at Reading Sevenoaks (Meridian dealer). I have re-typed and also loaded the latest firmware but still no sound. Meridian have also replied but think that it is a Roon settings problem.

I have also taken up Nic’s suggestion and scanned my network. This does show the ID41, so it is visible to my router and switches. The lights flash on the ID41 input.

There is a curiosity which I do not understand. If the USB connection between PC and 808 is made, then the ID41 connection is visible and appears to play with the sound meter active, although there is no sound. If the USB connection is disconnected, only “system output” is displayed in “Zones”; in “Settings” this now shows “system output” enabled; USB is visible but labelled “enabling” in red; Realtek HD Audio is visible with tab to enable (irrelevant PC soundcard); no ID41/Meridian 800 are visible but lights continue to flash on the ID41 input to the 808.

I would be grateful for any further suggestions anyone can make.

One further clarification is that my PC is running Windows 8 with an AMD A8 processor. I don’t know whether this is powerful enough to run Roon Core and Control, although it will run with the USB connection. (If I get this running I will probably get something with an i7 to run Core.)


You may have already covered this with Joel and others, however, in my experience the ID41 in an 808 needs to be configured with a ‘Sooloos System’ device rather than a MC200. The ‘Sooloos System’ allows one to connect to the ‘Net’ input on the 808 (which is what you want and need for the ID41) whereas the MC200 allows SPDIF, analogue and Speakerlink but NOT the network interface which is the one you need.

I know this is counter intuitive, however, the MC200 outputs refer to its own local zone outputs rather than the core output which is of interest here. If you configure your 808 with a ‘Sooloos System’ connected to the ‘Net’ input on the 808, the Roon core will see and be able to use 808 network interface and the ID41 will work as expected with Roon.

As above, you may have already tried this, however, if not, suggest you try the above.


Hello John

As you suspected, Joel changed my config to the route you suggest. Nevertheless, I am very grateful for your interest and suggestion.


My only other suggestion is to make sure that you are running the latest firmware on the ID41 card. This is separate from the 808 firmware and requires the use of ‘Meridian Device Manager’ running on a PC.

You should not need this just to get the system working yet it is worth making sure that your have the latest firmware and might just provide something of a reset kick. You can easily see which version you have installed by opening a browser pointed to the ID41’s IP address and seeing what the interface looks like - it changed significantly with the latest firmware. If the latest, it will say ‘Software version 1.2, build 218’ within the Identification field of the page.


Hello again, John

Thanks John for your further suggestion. Surprisingly, Des at Meridian recommended staying with the old ID41 firmware until this problem was resolved. I shall certainly install the new firmware if/when/ this problem is solved.

Many thanks


Hello @Howard_Leathlean,

I have been looking over your thread and it looks like you have quite a complex network setup.
My first and foremost suggestion is to simplify the network and verify if the network works in the most basic state.

Please try plugging in your PC and the ID41 directly into your router or into an unmanaged switch, to remove the other switches from the equation.

We have sometimes seen managed switches cause issues with Roon if improperly configured, so it’s good to eliminate this aspect, see Networking Best Practices KB for more info regarding switches.

Hello Noris
Thanks for your interest and suggestion. Unfortunately the router is in a different room from the PC and ID41 and it is not practical to connect the ID41 directly to the router. However, the combination of Roon and ID41 did not work even when trying to play locally stored music files from the PC that is also running Roon. The switches have both been “factory re-set” so the managed aspect is not active.
Many thanks
P.S. Everything performs faultlessly via the USB connection, including internet streaming. This encourages me to think that the problem does not lie with the switches.

The problem may be caused by my firewall. I have tried turning off my Windows firewall and also TalkTalk F Secure but perhaps this is still stopping Roon from working?