Connection to Euphony Server [Resolved - "Watchguard" firewall]

I recently installed a new music server running Euphony. I used to run Roon on Win10, but played with Euphony and it sounds much better! So I bought it. I’m running Euphony on the same hardware as I was before with Win10. It’s a ZBOX-RI531-U Mini-PC running Euphony on a 1Tb HD connected to my WiFi using a WatchGuard Firebox as my router.
I also have an iPhone X. All the devices are on the same network using DHCP. The Roon core is Version 1.4 (build 294) stable.
Problem is the iPad has a very hard time staying connected to the Roon core. It’s sitting there showing the Core is ‘initializing’. Yet I can connect right away with my iPhone (they’re right beside each other-and there are times the iPhone won’t connect too). The iPad is connected to my WiFi as I can browse to the web page of the Euphony server and bring up it’s menu. Here I can reboot the server. Once I reboot the iPad will connect the 1st time, but if I switch to another app then come back it can’t find the Core again.
What’s going on??

P.S. I’ve rebooted the iPad, uninstalled and reinstalled Roon remote-no difference. I’ve also bounced this off Euphony supprt and they suggest it’s not a problem with the Roon core running on Euphony.

I’ve moved your question across to the Support section, where someone from @support will see it.

Hi @Eldon_Doucet ----- Thank you for the report and sharing your feedback with us. The insight is very appreciated and my apologies for the wait here.

Moving forward, I would like to enable diagnostics on your account so we can try to get a better understanding of what could be causing this behavior with your remote device(s). With this in mind may I kindly ask you to please perform the following:

  • Note the time of day when the iPad is showing the “initializing screen” and fails to connect.

  • Note the time of day when the server is rebooted and the iPad will stay connected if you do not switch to another application on the device.

Once I have the above time frames I will enable the mentioned diagnostics on your account as this action will automatically generate/upload a diagnostics report to our servers which will contain a set of your Roon logs the next time Roon is active on your core machine and the iPad remote.

Additionally, at your earliest convenience, it would be great if you could also fill out the survey found here. We use this document when addressing remote connectivity issue.

Many thanks!

Finally saw your reply. I’ll let you know when I’m able to get at this.

Just finished submitting the information form you requested.
Started the Roon server approx 4pm EST and the iPad worked fine, switching in and out from other apps. Approx 4:15pm it lost connection to the Core and it wouldn’t reconnect. I then filled in your form and the iPad only reconnected when I restarted the core (approx 4:35pm). I also power-cycled the TP-Link Av500 at my home theatre location at this time.

The Core Server or the computer?

There the same thing. The Roon core runs on the Euphony server. Roon is built-in as part of the Euphony program.

If I don’t switch apps on the iPad it stays connected.

It’s 5:00pm now and I’ve been running fine since the last reboot at 4:35. And I’ve been switching apps.

5:22pm. Just switched apps and now won’t connect to the Roon core from my iPad. Tried it on my iPhone and it connected right away

5:30pm. Now the iPhone has also lost connection. Through all this the desktop app works fine-it has never disconnected (but I’ve only been using it for a few days)

No they are not. Roon is a separate software. Euphony is just a modified Linux with software pre-installed.

Ok. But Roon runs on the computer/Linux system from Euphony, so when you asked the core server or the computer, they’re the same thing to me. I can boot one or the other separately.

5:39pm. The iPhone let me reconnect, but the iPad won’t. Weird.

5:54pm. Desktop app still working. Both iPad & iPhone won’t reconnect.

Hi @Eldon_Doucet ---- Thank you for the follow up and time frames, as well as the survey answers. The feedback is appreciated!

As mentioned in my previous now that I have a sense as to when the error occurred I will go ahead and enable diagnostics on your account. Now that diagnostics are active I just want to provide a friendly reminder that all the elements that were used to note the time of errors should still be in place for us to successfully receive the report. We should receive the diagnostics report the next time Roon is active on the core machine and the remote devices that were used during your timestamp gathering exercise.

I will confirm when the report makes it to our server, thanks again!

Hi @Eldon_Doucet ---- I wanted to touch base with you on the above. I checked our servers today and I can see that we have received diagnostics from your core machine and a handful of remote devices.

I want to make sure that the tech team gets what they need to properly evaluate this issues and I wanted to see if it would be possible for you to verify the IP addresses of the remotes used during the troubleshooting exercise so we can check them up against the traces found in your logs. You can send this information to me in PM.


Hi @Eldon_Doucet ---- Thank you again for providing the requested information in a PM addressed to me!

Moving forward, the diagnostics report has arrived and I am updating your ticket to be passed over to our tech team for evaluation.

In the meantime I am curious about something. In your initial post you mentioned that your Roon core was originally being hosted on a Win10 and then you switched over to the Euphony. Did you ever experience the same behavior with your remotes when your core was being hosted on the Win10 device?