Connection to Roon ARC Impossible!

Roon Core Machine

Roon Core With SonicTransporter I5 (Gen 3)

Networking Gear & Setup Details

Asus router (ZenWifi AX) Connected To SFR Box
SonicTransporter Connected To Asus
UPnP on for Asus

  1. Who is your internet service provider?
    SFR Box

  2. Please list the make and model of your modem and router?
    Asus router (ZenWifi AX)

  3. Do you have any additional network hardware, like additional routers or managed switches?
    Switches Silent Angel Bonn N8

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

USB / SoTM SM200 neo / DAC Teac UD 503

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?


“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

Can you check that your ISP modem is in bridge mode? It looks like you have a double NAT setup, i.e., two routers.

I would also double check to see if you are being connected via CGNAT. Many posts online seem to indicate you ISP has switched to such. This would involve a call to your ISP and asking, and if you are on CGNAT, you can ask that they take you off and give you a public IP address for port forwarding.

Hi @Christophe_BRETON ,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode or forward the port on both modem and router

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.