Connection to Roon Remote fails after a few minutes [Solved]

Core Machine (Operating system/System info/Roon build number)

WIN10 64 bit Intel i5 3.2GHz 8GB RAM / Roon build 571 64 bit

WiFi: SSID: BTWholeHome-N9WF
Protocol: Wi-Fi 5 (802.11ac)
Security type: WPA2-Personal
Network band: 5 GHz
Network channel: 36
Link-local IPv6 address: fe80::fd8d:a82e:b0ba:2d75%21
IPv6 DNS servers: fe80::7a65:59ff:fe8d:cc8e%21
IPv4 address:
IPv4 DNS servers:
Manufacturer: Intel Corporation
Description: Intel® Wireless-AC 9260 160MHz
Driver version:
Physical address (MAC): 24-EE-9A-1E-F1-7C


USB Focusrite USB audio WASAPI drivers

Have set up trial version of Roon successfully on my PC as Core. Roon Remote is installed on a Sony Xperia XZ2 running Android 10. Connection can be made over WiFi - both running on same network IP address: 192.168.1.***. I find the only method of making connection is to open Roon Remote first and then start Roon Core. Roon Remote finds the Core immediately and connection can be made. All seems to work - can connect to Qobuz in Roon remote, etc. However after about 5 minutes the connection between Remote and Core fails. The only method that works to restart is to open Roon Remote first and then start Core, as above.

I normally run with Widows Firewall on, but have switched this off and problem still occurs.

Have tried using Ethernet connection of PC to router rather than WiFi, but this also makes no difference.

If I cannot solve this issue, I will not be subscribing after the trial period ends.

Hi @Andrew_Bell,

Do you by any chance have IGMP Proxying / IGMP Snooping settings you could try toggling in your router? We have sometimes seen that Android devices are more susceptible to multicast protocol issues, and Roon uses multicast for device/core discovery.

If you get the cannot connect to Core page, at the bottom there might be a blue link HELP, click it and it will give you the option of entering in a server IP, use instead of the actual IP.

Thanks Noris, however that doesn’t appear to be a parameter I can change on a BT Hub. However, problem solved - see below

1 Like

Hey Rugby - many thanks - this worked, in a way. I clicked Help on Remote and found the host manual entry. I entered the host name rather than an IP address and remote found it immediately, (but no surprise as the Remote can always find the host if I close and re-open the Core). However, after this action it no longer drops the connection whilst Remote is open and now seems absolutely stable. It maybe takes 3 or 4 seconds to make contact to the host again on opening up Remote on the phone, but I can certainly live with that…Many thanks.

I don’t really understand why it is now stable, having connected manually only once, when automatic connection worked, but wasn’t stable. Maybe it is something to do with the way it stores the host name - or maybe our BT Whole Home WiFi system has some fluidity in IP address assignments, so that the Host Name is the most stable way of locating the Core.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.