Constant dropouts and lags on the iPad & Roon itself

So my setup is as follows: Mac mini (2014) with roon and a 4TB hdd connected with a Tidal hifi. Then living room auralic Aries and benchmark Dac 2 hgc. Roon works most of the time but lately tidal tracks dropout and the iPad constantly has to reconnect to my Mac mini. I just changed modems and routers and I pull pretty nice speeds. I am now thinking maybe my Mac mini is not enough. Not sure though.



Hi @Abrahams_Bogere,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

If you play local content instead of TIDAL content does the same behavior occur?

The router I am using is a Sagecom 5280. I am using the 5Ghz channel to the Mac mini upstairs, auralic and ipad/iPhone. I turned off the MQA renderer which may have been the issue but i am not totally sure. Would I need to change port settings or something?

You might try setting your Sagecom 5280 to a lower 5GHz channel like 36 and see if it helps. Note which one it’s on currently, like 48, so you can go back if it’s worse.

This will cause the wireless router to use a longer wavelength that is better able to penetrate walls and ceilings.

I thought there is only 2ghz and 5 ghz channels? Unless you mean something within the settings I should look at?

Those are the frequency bands, within them are multiple channels, slices of the band if you will. For 2.4GHz, set it to automatically select the least congested channel. For 5Ghz, it’s often best to ‘tune’ to your needs. It sounds like your Mac might not be getting a strong enough signal. Lowering the 5Ghz channel (there are 4 to choose from 36,40,44,48) You may see more higher numbers but you want to try the lowest first.

You’ll have to refer to the manual to see where and if they are changeable.

I found that setting today. I tuned it to the highest I saw. I wish I could tell which is congested and which one isn’t. So far it’s work a bit better. I may have to switch to 2.4ghz eventually.

There are number of apps for phones that will tell you which WiFi channels are more congested than others. You are really advised not to use 2.4ghz as it’s the most overly congested frequency regardless of the band and will likely cause even more issues… Your core would be better served hardwired in general as it requires a very steady connection to function properly and full duplex which wireless cannot provide.

Try the lowest number you have available. This will give the best range but checking congestion is a good idea. As the other poster said, if your radio doesn’t tell you, apps for smart phones can.

Hi @Abrahams_Bogere,

If you connect the Core machine via Ethernet instead of WiFi does the same behavior occur?

Hey man! Recently I just upgraded to an SSD on my core. Things are running a lot better than before for now

1 Like

Hi @Abrahams_Bogere,

Glad to hear that Roon is up and running with the extra storage! Dylan is no longer on staff at Roon, but if anything comes up, please feel free to tag the support team in a new thread and we’ll be there to assist.