Continuing switching Audiosections on and off

(Frank Nickel) #1

This is a big bummer. Just when I thought to buy Roon I get a problem which makes the hole thing unworkable.
First my specs:
Network 1GB. Modem FritzBox 7360, kabels 5Cat
Roon Core1.6 64 bit on NAS Synology 1511+
Roon Bridge 1.6 64 bit on Media PC 8GB SSD 120 GB WIN 7
Roon Bridge 1.5 64 bit on Asus Laptop 8GB SSD 250 GB WIN 10
Output Denon AVR 4520 via Airplay
Output Oppo 205
Control OnePlus 5T Android 9.0 8 GB
Control Huawei Mediapad Android 7.1 4 GB
I cannot connect to any audio source. In the AudioTab it keeps searching trying to connect searching again. For a view seconds some devices are recognized, only to disconnect again. The only connection which is achieved is via AirPlay to the Denon AVR.
This issue just started today without any changes in the settings
This is quite frustrating as I only have one day left for the trial, so I’m afraid I have to sign out.

(Noris) #4

Hi @Frank_Nickel,

The issue you described is most often attributed to some kind of firewall blocking Roon from operating properly. I noticed that you have a FritzBox router, we have that listed as a router that requires special settings applied for it to work properly in our documentation.

I have also seen similar behavior if the Synology has “Open VSwitch” turned on (see Lost my KEF LS 50 wireless connection [Solved - Synology had "Enable Open Vswitch" turned on]).

Please let me know if that helps!

– Noris

(Frank Nickel) #5

Hello Noris,

thanks for your reply. However, I don’t have the time to test this as I will be away for a couple of days. So I had to cancel my account yesterday due to the fact that there is only one day left for the free trial.

Anyway, thank you for your help!

Kind regards

(Noris) #9

Hello @Frank_Nickel,

Eric told me that you spoke and that you have decided to continue troubleshooting this issue with us. Once you are ready to proceed please give my last suggestion a try and let me know if it helps!


(Frank Nickel) #10

Hello Noris, hello Eric.

first my apologies for the late reply. Our internet provider had in its infinitive wisdom shut down our line for 4 days. :joy:
My Fritzbox is (luckily!?) to old for the OS 7. The latest firmware is 6.85. When I run Roon core on my Media PC everything works fine, so I ruled out the router.
Rests the Synology: I installed RoonCore back on the Synology. Then I looked up your suggestion of the possibility to disable the Open VSwitch but couldn’t find this option so far. However, I also had trouble to connect my wireless devices via WebDav, for instance with the Software Kodi to get to the Movie libraries. It showed the same behavior as the audio connection in Roon, trying to connect until my server blocked the devices.
I went to the Account settings and disabled the IP blocking option in the secure settings. From that moment on Roon worked fine.
So the issue indeed lies within the settings of the DSM from Synology. I will look into this further as it is not desirable to leave that security option disabled. I believe something has changed during the latest DSM update.
So far so good.
Thanx again for your help!
Meanwhile I found another “issue” with sound dropouts while streaming media on wireless devices with Bluetooth enabled. I believe I saw something similar already in the forum. I will check this also.
Greetings form Holland


(Noris) #11

Hello @Frank_Nickel,

Glad to hear that you’re up and running again after disabling the IP blocking setting!
Please do keep us posted with your findings, I am interested in hearing more about the Bluetooth issue if you are able to reproduce that as well.


(Frank Nickel) #12

Hello Noris.

okay here’s the second challenge:

Wireless streaming on Oneplus 5T, Huawei MediaPad and IPad MIni works fine.
That changes when I connect them to my Denon Envaya mini via Blutooth.
The OnePlus 5T streams flawless without any problems.
The Huawei Media pad and the IPad Mini (OS IX) have dropouts and finally the hole track skips to the next one with the same effect of dropouts.
I made shuire that the bitrates on the Android devices are the same (48K, 16 bits).
On the IPad there is no possibility of changing the Bitrate.
I believe I red something familiar on the forum?
By the way: All music files are on the Synology NAS and all files are flac files, varying from 44.200, 16 bit stereo to 192.000 24bits surround.

Have you already heard of this problem?

(Noris) #13

Hi @Frank_Nickel,

Where are you making the Bluetooth connection? Is it being connected to the Core or are you connecting it to each of the Roon Remotes? How far away is the Denon Envaya from the source?

Can you right click the zone in the bottom right-hand corner and post a screenshot of the Device Setup tab with the advanced options listed as well? This screenshot should look something like this:


(Frank Nickel) #14

Hi Noris,

There is no Bluetooth Connection to the core.
The Remotes make connection to the speaker. They are literally lying near the speaker so there is hardly no distance at all.
First the screenshot of The OnePlus 5T which is working fine.

The next one is from the Huawei MediaPad which has the drop-outs.

Here the screenshot of the IPad which also has the dropouts.

All devices where tested via Bluetooth one after another to prevent blocking each other.
I also tried different sample rates and Bit depths with no effect.


(Noris) #15

Hi @Frank_Nickel,

Thanks for posting those screenshots and for expanding on the issue.

I would like to separate the possible causes here, can I ask if you experience this issue when outputting to the Roon Remote speakers such as the iPad itself? Is there any issue doing just that?

Also, what if you try to stream tracks outside of Roon, for example if you use the bluetooth Denon with TIDAL/Qobuz/Spotify/Youtube, does that work as expected with no issues?


(Frank Nickel) #16

Hi Noris,

the problem only occurs with Bluetooth. When I stream only using the speakers - or using a wired connection, such as a headphone - everything works fine.
When I use different software for streaming, like DS audio from Synology or JRiver, I don’t have problems using Bluetooth. Same goes for Spotify, Youtube.
When I use Kodi for streaming Movies I also have no problems with Bluetooth. In this case however there is a quite some latency which I have to correct in the audio section of Kodi by changing the audio delay to about 200 mseconds.
So actually, the problem only appears with Roon.
I tried different Sample rates and Bit rates but this seems to have no effect on the problem.

(Noris) #17

Hi @Frank_Nickel,

Thanks for confirming that for me. I would like to see if diagnostics might help here.

Can I please ask you to reproduce this issue once more, then note the exact local time in your country that it occurs at (such as 10:01PM) and which remote you used and then manually send us the diagnostics from your Core using these instructions?

If you don’t have Dropbox or Google Drive just let me know and I can provide an alternate upload method.


(Frank Nickel) #18

Hello Noris,

I just finished the test and created the log. I don’t have Dropbox, so please provide me with an alternative.
I will describe what I have done.
start test at 16:08 European time.
I started with the IPad mini, Bluetooth connected to the Denon Envia Mini. Played file (24 bits 96 KH). Dropouts with message in Roon Remote: An audio file is loading slowly. This may indicate a performance or hardware problem.
16:11 I switched to a track (16 bits 44.1kh). Same effect, same message.
16:14 I turned of Bluetooth, hardwired the IPad with my headphone and everything plays fine.
16:17 While leaving the IPad running, I started the One-plus 5T, connected via Bluetooth to the Denon Envia Mini, playing without any problems.
16:19 While leaving both devices streaming I started the Huawei Media-pad, streaming on its own speakers without any problems.
So from that moment on all three devices were streaming at the same time.
16:25 I stopped all devices.
The reason for doing this was to make sure that my WiFi network is not he issue here.

I hope this helps. If you need more testing just let me know.


(Noris) #19

Hello @Frank_Nickel,

Thank you for reproducing the issue and noting the timestamps, I have just private messaged you upload instructions. Thanks!

– Noris

(Frank Nickel) #20

Hello Noris,

I uploaded the file. The filename is Frank Nickel

(Noris) #21

Hello @Frank_Nickel,

Thank you for submitting those files. I just wanted to check in with you here and let you know that we are still investigating on our end but I do have one slight suggestion here to see if it changes anything – can you please try disabling MQA Core Decoder? I suspect it won’t really change much but just something that we can try in case that affects the bluetooth stream from your Roon Remotes.


(Frank Nickel) #22

Thanks Noris.

Unfortunately switching off MQA doesn’t change the situation. Meanwhile I was testing my OnePlus 5T outside my house in the garden with lesser WiFi signal (about 60%) and even there it works like a charm. Same goes for the other two devices when Bluetooth is switched off. So there is definitely nothing wrong with the speed of my WiFi.

It’s really strange that the other two devices (Apple and Huawei) have issues with the combination Bluetooth via Roon while there is no problem on my OnePlus whatsoever.

(Frank Nickel) #23

Yesterday I tested another Bluetooth speaker as a kind of cross-check. It is a Jabra Speak 510 - far from HiRes but good enough for testing. The result was that now my OnePlus 5T had the problems with stuttering audio and skipping files while the Huawei MediaPad had not.
I then tested one of my Laptops with wireless streaming and Bluetooth connection to both speakers and that just worked fine.
So the overall conclusion so far:
All my Android and Apple devices have issues with streaming via Bluetooth on Roon.

(Noris) #24

Hi @Frank_Nickel,

Thanks for running that test. I have asked the team to perform some testing to see if they are able to reproduce this issue on their Android devices but just as a note, I have tried to reproduce your report on my end today and I have been outputting content via Bluetooth on my iPhone X as expected to multiple zones, including a UE Boom 2 and a pair of bluetooth headphones without issue.

I believe you mentioned that you were on iOS 9 on the iPad and on older versions of firmware for the Android devices as well, I am wondering if this could be due to something causing issues on the older firmware. Also, when you are outputting via these Bluetooth devices, what does the Signal Path report as the Processing Speed? Can you please share a few screenshots?


(Frank Nickel) #25

The iPad mini runs on IOS 12.1.4
The OnePlus 5T runs on Android 9.0.3
The Huawei MediaPad runs on Android 7, last updated december 2018.
So not actually the oldest devices. I trust I don’t have to buy new devices every year? Just kidding :slight_smile:
The attachmet is from the iPad Mini.

Meanwhile I noticed quite some increasing quality loss concerning the combination BlueTooth-WiFi, now suddenly appearing also on other programs. So I believe we can rule out Roon to be the malefactor here.
Still quite frustrating tho as I am only able to use my BlueTooth speaker without BlueTooth and I don’t have any clue what’s causing this.
The only thing I can think of is increasing strength of neighbour WiFi networks. I’ve read that BlueTooth uses the same frequency as the low-band Wifi (2.4GH).
I’m wondering whether changing the router to a newer model could help, but that’s not the topic here.
So I think we have to leave it here…