Control4 Roon Zone "Waiting for Zone" (v12 Control4 Driver)

G’day guys,

We have a customer with a Roon player and the Roon Zone/core v12 driver on control4

Roon Core is saying “Ready”, version 1.7 stable.

The Roon Zone however has the UUID in the core correctly, but the Zone list is empty, and it says waiting for zone.

It was working originally (and I assume since Roon Core is ready, that the IP is correct, and working)

Is this a bug in the V12 drivers, or is there a way to diagnose this remotely… Unfortunately we are in the middle of lockdown so are unable to go out onsite to fix the issue. Any ideas?

Hi @Andrew_Luecke,

Welcome to the forum!

I would try a reboot of the Nucleus and/or the Control4 processor. If that does not work, you can try:

  1. Setting the Core IP in the module again (where it says edit this field, re-input IP of Nucleus and Set)

  2. Ask the user to make sure that the module is enabled in the Roon UI, under Roon Settings -> Extensions. If there is an Enable button there, user should click it.

  3. Un-authorize and re-authorize the extension on Roon Settings -> Extensions - Authroizations. Once extension is unauthroized it should automatically re-appear, but if it does not, you can try a reboot of the Nucleus.

Hope this helps!

Thanks for the response. Already tried rebooting…

One other thing we’d like to try is downgrading the driver though… any chance anyone has a copy of the v11 driver? We’re currently in lockdown, so really hard to get out

Hi @Andrew_Luecke,

You can try an older version of the driver, but we have fixed a lot of issues with build 12, so I suggest that you remain on build 12 for best stability:

Build 12

  • Fixed: Volume control on Control4 OS3
  • Fixed: Playback commands when multiple zones are grouped
  • Added: HDMI blinding to audio/video zone driver output

Has the user tried to remove the authorization for the extension in their Roon Settings -> Extensions tab and re-authorize it there?

It seems like there is at least partial communication with the module since the status for the Core is Ready.