Control4 zoning


(Daniel Lee) #1

I’ve added nucleus+ to Control4 but I can’t group zones. It works through the Roon app but not through C4. I’ve made all the necessary connections and also tried auto zoning in the actions tab.
Kit using in this project are Meridian 218s, 251s and 818v3.


(Noris) #3

Hello @Daniel_Lee,

Thank you for contacting support regarding this clarification request. I am seeing some strange behavior when trying to group zones in Control4 and as such I have filed a request with the dev team to take a closer look at this behavior. I will be sure to let you know once I hear back from them regarding this feature and we’ll make sure we figure out what’s going wrong here.

Thanks,
Noris


(Noris) #4

Hello @Daniel_Lee,

I am still waiting to hear back from the dev team regarding zone grouping but in the meantime I wanted to ask you what you Control4 connections looked like. Can you please post a screenshot of your Connections tab under Composer -> Roon Core -> Zone Grouping 1? I have set my zone grouping as follows and grouping zones is working on my end:

Please let me know if you are able to set it as something similar and if it works for you.

Thanks,
Noris


(Daniel Lee) #5

Hi Noris,

Please find attached screen shots of the connections.

The only thing I can see different is the Audio/Video Outputs that I change and tried with no joy.

Thanks
Daniel


(Noris) #6

Hello @Daniel_Lee,

Thank you for posting those screenshots. Can you please let me know what devices you are attempting to group there? As stated in our Control4 User Guide, zone grouping only works with devices that use the same communication protocol (RAAT/Airplay/SONOS) and some devices cannot be grouped with others (Meridian zones can only be grouped with Meridian).

I would try removing any non-meridian zones from there and create a separate grouping for them. Please be sure to only group similar devices that are listed in the User Guide and afterwards please let me know if you are still running into issues.

Thanks,
Noris


(Daniel Lee) #7

Hi Noris,

Device list,
Office - Meridian 218
Living Room - Meridian 218
Master Bedroom - Meridian 251
Living Room TV - Meridian 218
Dining Room - Meridian 818v3
Kitchen - Meridian 218
Master Bathroom - Meridian 251

it all works through the Roon app.

thanks


(Noris) #8

Hello @Daniel_Lee,

Thank you for providing the list of Meridian devices in use. I’m going to check with our dev and QA team to make sure we can confirm linking is working with Meridian zones in Control4 and will update you as soon as I hear back. I appreciate your patience here until I hear back.

Thanks,
Noris


(Noris) #9

Hello @Daniel_Lee,

I appreciate your patience here while we looked into this behavior. I have done some tests with grouping Meridian Zones on my end and I have a few questions as to request clarification:

  • Does the Control4 Extension show up properly in your Roon Remote App? It should be listed as follows:

  • Your Control & Audio Video Connections setup looks correct according to our devs. Can you please confirm that these zones work individually within the Control4 module? As in if you don’t group them together, are you able to select and play to just one of your meridian zones?

  • Can you please open your Roon app and select one of the Meridian zones as the current zone, the Office Meridian 218 for example. Then while keeping Roon open in the background, please try to add your Living Room Meridian 218 zone using the Control4 touch panel by pressing the “home with a note button in it” in the bottom right-hand corner of your touch panel and selecting “Add Room…”. Do the two zones show up as expected in the Roon app and are properly grouped? The two grouped zones should be listed in the bottom bar of your Roon app (with your zone names):

    After grouping two zones, I would keep adding more of your Meridian zones and verify if the addition of any specific meridian zones causing the grouping to not properly work.

Please let me know if you are able to provide clarification to my above questions.

Thanks,
Noris


(Daniel Lee) #10

Hi Noris,

i have the Control:4 1.0 Roon Labs, LLC in extensions.

Control4 is controlling each zone but just not grouping.

looking at the Control4 app it doesn’t show that i have grouped zones in the Roon app.

thanks


(Noris) #11

Hello @Daniel_Lee,

Thanks for confirming that the Control4 Extensions shows up properly. I am having a bit of trouble understanding how you are adding these zones in Control4, can you please confirm that you are using the “Add Room” buttons via your Control4 touchpanel? Does selecting one of your room zones and then adding another room zone show up as grouped zones in the Roon App?

I have outlined the process below with my current zones (using Dragonfly Red & System Output as my example here but tested these steps with a few Meridian zones as well and the steps remain the same):

  1. On your C4 touchpanel select one of the Meridian Zones, and press the room icon in the bottom right-hand corner:

  2. Press “Add Room…” on the Rooms selection screen

  3. Add one of your Meridian Zones to the Group:

  4. Meridian Zone will show up underneath the other zone:

  5. Check in the Roon App to make sure that they are grouped:
    image

I would try adding your Meridian Zones one at a time and if it doesn’t group properly in the Roon app, please let me know if the addition of one of the specific zones causes issues.

Thanks,
Noris


(Daniel Lee) #12

Hi Noris,

yes that is the way ive been tring. no grouping works.


(Noris) #13

Hello @Daniel_Lee,

We have been trying to reproduce your findings on our end but have been unable to do so thus far, I am not sure what but something must be different regarding your setup vs what we have been able to test in the lab, do you have any ideas at all what that could be?

I have a few other questions to clarify the issue further: Does grouping regular non-meridian zones work as expected? Have you experienced this issue with other installs as well or just this one install? Would it be possible for you to provide us a video of the grouping behavior you experience in Control4 vs what you are seeing happen in Roon as to have a better understanding of this issue? I can forward the video to the devs to take a look and it would really help clarify what exactly you’re experiencing.

I do apologize about the frustration here, on our end this seems to behave as expected so I am not quite sure what could be causing the different behavior on your end. I look forward to hearing your thoughts on my above questions and if you are able to provide a video showing this issue that would greatly help us in moving forward.

Thanks,
Noris