Controlling Roon from the iOS Notification Center as a widget (Using Workflow App)

I HThanks.
No, did not work. I’ve done exactly that. Just with the my IP.
It seems to stop on the last action. (Get contents of URL).

Edit found the error. (I wrote “server” did not take from menu).

Now new error:


Which seems to blame HQPlayer ?

So I switch sone with same result:

{“outputs”:[{“volume”:{“max”:100,“min”:0,“value”:55,“step”:1,“type”:“number”,“is_muted”:false},“can_group_with_output_ids”:[“1701a649604fbbf30f98af50fdc6734078a7”,“170148f08eb53e88b35a244cf8b477e344e7”,“1701e28fefb67c06a9ed4e2078bd8793728d”,“17019ac30dfcb6527bf8ca2613108895b722”],“display_name”:“Radio Terasse”,“zone_id”:“1601e28fefb67c06a9ed4e2078bd8793728d”,“output_id”:“1701e28fefb67c06a9ed4e2078bd8793728d”}],“is_seek_allowed”:false,“is_previous_allowed”:false,“is_play_allowed”:false,“zone_id”:“1601e28fefb67c06a9ed4e2078bd8793728d”,“is_next_allowed”:true,“display_name”:“Radio Terasse”,“is_pause_allowed”:false,“state”:“stopped”,“settings”:{“shuffle”:false,“auto_radio”:true,“loop”:“disabled”}}

So maybe not HQPlayer at all. (This is a Squeezebox Radio).


Am I correct in assuming you’re attempting to write the Workflow manually? What’s happening is that the first GET request is to populate the zone list, so if you’re only using the first four steps in the Workflow (as in the screenshot I posted, which is incomplete), all you’re seeing is raw information about the zone. I would recommend importing the Workflow in full, and using it as is (with the server address changed, of course). Here’s the link (view on your iOS device):

Let me know how you get on with that.

Thanks. That was a lot better :grinning:

Still, my workflow is opening in the workflow app, and not in the wideget, as shown in a post earlier.

So I guess there is a trick to make it stay in the widget world ?


I’m glad that you’ve managed to get it working. Is it kicking you into the Workflow app when you start it from the Notification Center widget? That’s very odd, does your widget look something like this before you start?


I guess my widget looks like yours.

I changed from a computer that was wireless connected to my HTPC.
So now we have a different issue. Se picture. It can’t find my Zones.

Suggestion ?

It’s working. Just to start it inside Extention :grinning:


Very cool little tool!

I got this working on a zone named “Living” with a single endpoint however in a separate zone named “Bar” which is a group containing “Dining Room” and “Kitchen” it does not respond to commands. In the workflow widget it is listed as “Dining Room + 1”, perhaps this is part of the issue? Is it a know issue with the Roon API perhaps? I tried via http commands and I can get living working but not “Bar”, “Dining Room + Kitchen” or “Dining Room + 1”. Any thoughts?

Thanks for the development gone into this - it’s nice not having to carry around a remote/phone/tablet and be able control music playback from my watch.
Would you be interested in adding your extension to the Roon Extension Manager project? Details of that here Roon Extension Manager v0.7.1

@Jan_Koudijs - is there any reason this would not qualify?

Thanks! That’s interesting, I haven’t really experimented much with grouped zones. I have a feeling it’s a problem with my implementation, I might be explicitly looking for single zones, where grouped zones get excluded. I’m not sure whether there is a distinction or not, but I’ll try and take a look and get back to you. If you think you might be able to tinker with it yourself, feel free to submit a pull request.

That sounds great, what do I need to do on my end?

Check out the “Join the development” part within the Roon Extension Manager v0.7.1 post. Jan, the dev will help you out I’m sure.

Main criteria for inclusion is that the developer wants his extension to be included :slight_smile:

Add an entry to the repository file for your extension and give me a pull request.

1 Like

Hi Jan, I created the pull request, glad to be part of the project!


Your extension is in!

Users that have enabled auto update can install it after the next update cycle.


Cool, does ist work with ROCK?

I know this is an old thread, but I’m wondering if anybody is still willing to offer a little help. If so…

I’m using an 8i3 NUC, and port 3000 results in a “Server not found” error. If I delete the port number the shortcut runs, but it doesn’t actually do anything.

Any sense of what I’m doing wrong? Many thanks to anybody who knows more about this than I do (which is damn near everybody).


I couldn’t see this extension.
Is it still in your library?

Found it :grinning:


I’m attempting to do this following the instructions provided. But I’m stuck and I don’t understand what to do next. Hoping you will help me out with some step by step instructions for someone who’s never done this before and doesn’t understand what some of the terminology means. Here’s the point where I do not understand what to do:

Set up the server

  1. On the machine that you want to run the server from (usually best to do so on your Roon core), git clone this repository into a suitable location (you may need to install Git if you haven’t already, although installing Node.js requires Git).

I appreciate I’m resurrecting an old thread. It seems like the Apple Shortcuts app has replaced and should do everything workflow used to, but the link provided to your app no longer works.

Can someone either share a link to a current Apple shortcut app with all the functionality of the remote, or the code for me to copy/paste into the app?
I’m really keen to get this working, but less keen to reinvent the wheel unless I have to!
Thanks in advance

I don’t think you need to do all this now that there’s an Extension Manager app. In Roon go to Settings > Extensions and enable the Extension Manager. Once you’ve done that, you can find the RESTful Roon Remote in the Web/Connectivity list of extensions. Assuming that’s worked then the bit that’s left is to set up the commands on your phone (the bit I’m struggling with now).