Convolution filters, and sample rates >44.1, gives silence

Core Machine (Operating system/System info/Roon build number)

ROCK Version 1.0 (build 227) stable
ROON Version 1.7 (build 710) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Fixed network (ethernet) through TP-Link switch.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Topping D90 DAC over USB
Ropieee on Rpi4, version 3.020 stable

Description Of Issue

I use convolution filters generated from AudioLense via roon’s convolution filter for room correction.
Prior to the upgrade to Roon 1.7 build 710 all was fine. However after the upgrade, playing music with sample rate >44.1 results in silence. If I go into DSP settings and turn off the convolution filter, music starts again. I have tested this with local files as well as QoBuz streamed music.
44.1k/16bit material plays fine. 44.1k/24bit also fine.

While playing a “silent” track I get the following path:

Things I have tried:
Disable volume levelling. No change
Generating 32 bit filters rather than 64 bit. No change
Having a smaller set of filters (removing 192k rate). No change.

The DAC shows the correct sample rate for the material being played (e.g. 96k), but no signal.
I am happy to supply the zip file of the filters if you’ll let me know where to put them.

Thanks in advance


Sorry for the trouble here, @Paul_Davison! If you could, please zip up the files and upload them here:

We’ll take a look and follow up as soon as we can! Please note that it might be a bit longer than typical with the holidays approaching, though.


Thanks for responding Dylan, I’ve uploaded a zip file to the location you specified. I fully appreciate potentially slow support at this time of year :grinning:

1 Like

Thanks for the files @Paul_Davison, we’ve submitted them to the tech team for review!

A quick update on this issue. The release of 1.8 did not fix things. However I upgraded AudioLense to a newer version recently and re-generated the filters after doing fresh measurements (due to a DAC upgrade). The new filters do not exhibit the issue, so the issue has gone away for me.




This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.