Convolution not working for very specific use-case

When I run RoonServer on Windows (Server 2016 in my case), and have a RPi as an endpoint (RoonBridge), it seems that Convolution does not kick in for USB devices (but does work for Toslink or Coax attached devices).

If I move the server to Linux or MacOS, Convolution works as expected.

I’ve tried this with RPi running Ropieee and Raspbian - the problem persists across both. When the endpoint is changed (to say a fitler-i running Linux) the problem goes away - convolution works as expected. So it seems to be specific to the Rpi as an endpoint.

The DAC I’m running is the Kii Three, attached via USB.

The issue does not happen for another DAC (eg Cyrus soundKey), and doesn’t seem to be cable specific.

This should be easy to replicate to the specific configuration below!, namely:

Kii Three “loudspeakers”, attached via Kii Controller, attached vi USB to Rpi running RoonBridge, with RoonServer running on a Windows Server 2016 box (in my case Intel NUC). With all devices connected via Ethernet (no Wifi).


Thank you for the feedback and sharing this observation you have made with us @Aris_Theocharides, the insight is greatly appreciated!

I am going to be checking with our tech team to see if we have any Kii products available for testing in our QA lab but first want to make sure I am conceptualizing this behavior correctly.

  1. The issue occurs under the following circumstances, correct? See below.

    • RoonServer running on a WS 2016 based core
    • RPI (w/RoonBridge)(under Ropiee and Raspbian) - > USB - > Kii Three
  2. The issue does not occur under the following circumstances, correct? See below.

    • Same configuration (WS 2016 core > Rpi > Kii three), different connection type between the Rpi and Kii three (i.e Toslink or Coax).

    • Same configuration (WS 2016 core > Rpi > USB - > DAC), different device attached to the Rpi via USB (i.e Cyrus soundKey).

    • Same audiozone (Rpi - > USB - > Kii Three), different core operating system (i.e Linux or MacOS).


Hi Eric, Yes - that’s correct. Only the specific configuration seems to not let Convolution kick in. What happens when Convolution doesn’t work, is that the path simply looks like Convolution is turned off.


Thanks for getting in touch with me @Aris_Theocharides and providing the request feedback!

As mentioned, I am going to be raising your report with our tech team and seeing if we have any Kii gear in house we can test with. Once I have some feedback I will be sure to touch base again immediately. Your patience during this process is appreciated!


@Aris_Theocharides ---- Would it be possible for you to send us a sample filter that you are noticing this behavior with?

At your earliest convenience if you could please send the media over via a shared dropbox link in a PM addressed to me it would be very appreciated!

Additionally, can you please also provide a screenshot of your signal path when you notice the issue occurring.


PM Sent.

The screen shot is really simple (hard for me to get to now though). It’s the exact same as if Convolution is turned off.

Thank you for the follow up and PM @Aris_Theocharides, both are appreciated! A few things moving forward…

First, the filters have been received and downloaded, again, many thanks for the sample! Secondly, the tech team has asked if you could please not only provide a screenshot of your signal path as mentioned above but also complete screenshots of the DSP Engine window highlighting all the features being used when…

  1. You are using a USB connection between the RPI and the Kii threes (i.e when the issue is occurring).

  2. You are using one of the other mentioned connection types (i.e Toslink or Coax) between the RPI and the Kii threes (i.e when things are working as expected).

Looking forward to your follow up!

I’ve re-installed ropieee and connected it to the Kii Threes. I’ve made the Win2016Server box the RoonServer (called “AUDIOCONTROL”).

The first thing I noticed is that when I activated the Convolution, a white noise was heard and then no audio would play. The Kii Three Control would not appear in Roon, so I turned everything off (Kii Control, Pi).

After powering everything on, and going for a coffee, it seems to be behaving - and working, meaning Convolution via PI/USB and RoonServer on Win2016Server works correctly.

This has happened before, so I will leave it as is, use it normally and let you know when it breaks - which I expect to happen soon, over the course of the next couple of days.

Will be in touch.


1 Like