Core does not find new Roon Ready Bricasti M5 player [Resolved, network]

I have been trialing Roon with a Sonos setup and just got a new Bricasti M5 network player that is Roon Ready. I connected the M5 to the LAN in place of a Sonos device (that was working fine at this location in the network), powered up, and… Roon does not see the M5 as an Audio Device. The Bricasti is plug and play - no settings interface.
Roon Core is on QNAP NAS, latest version of Roon (1.4 (build 300) stable) and using iPAD or PC or Mac as remote. Core is on SSD attached to QNAP and QNAP is wired through a Netgear GS105 gigabit switch to Linksys EA9300 router with the Bricasti wired directly to the router.
Bricasti is on and LAN port lights in back of unit are flashing for network connectivity.
Screenshot of Settings>Audio attached.

Any help is appreciated

OK - is physically on the net, but are you sure that logically as well; is pinging?
DHCP etc…

Yes. Loaded Audirvana+ on a Mac connected by LAN cable to router. It sees the M5 and plays music. Going from Roon, it does not. I was on the phone with Bricasti support and his Roon Core shows the M5 without issue. He updated to version 1.4 build 300 (version I have) while I was on the line and it still worked. So it is something in my network. I moved the QNAP NAS from behind a switch to direct into the router. No change. Have now shut the network down and will restart things to see if perhaps there was a conflict of some sort.

I really want to get this resolved as I like Roon after the short trial I’ve had.

The Bricasti M5 has a web-based settings interface on port 8080.

You can load it by typing this into your web browser:

(replace with the address of your device

Since you can’t see it in Roon, that’s a sign that the Roon Ready support on the device either isn’t running, or that it’s looking for a USB device that isn’t there and is waiting for the device to be plugged in.

Check the Roon Ready setup page and make sure everything is right. In particular, make sure to set the output mode (AES/SPDIF or USB) appropriately.

If that doesn’t work, I suggest getting in touch with Bricasti to see if there are any other steps required to get this up + running.

I couldn’t find it’s ip address in my router network map or otherwise, which was puzzling as well. So the 8080 wasn’t an option.

But, I eventually found the fix:
I could access the M5 from my Mac with Audirvana but not Roon. When I tried mapping network music to Audivarna, I couldn’t see my NAS music folder. I checked the Mac System Network settings and saw the Mac’s ip was But my network is based on I set a fixed ip for Mac and could see music but the M5 disappeared. Ugh.

The culprit was a conflict of 2 networks, the 2nd coming from an old router serving as an access point in the detached garage/office. It was supposed to have its DHCP turned off, but somewhere along the way it reverted and it was running the network. I reset it as a true access point and the M5 appeared in Roon as it should.

Time for a beer and to listen to some music!