Core Drops out of play mode while using iPad to view other albums [Resolved - New core machine with SSD]

Roon Core running on Lenovo T530 with Windows 10 Pro at highest update level.
i7 intel with 8GB storage , 1TB HD, 1 TB Samsung external SSD.
WAV music file on SSD & Roon SW & Library on HD.
T530 is Ethernet connected & iPad is wifi using 802.11 AC connected MIMO.
iPad is new iPad Pro 10.5 256 GB running IOS 10.3.2
( problem also occurred with former IPad Air2 )
Roon core is at Ver 1.3 update 234 & ipad is at Roon 1.3 update 233 ( latest levels )

While playing an album on the T530 ( core & output ) when I start Roon on the iPad and than scroll quickly through
the list of albums to see what I want to play next the music stops & i notice that the track has dropped out of play. Most of the time I can just hit the play button again & it restarts playing but sometimes there is a delay before anything happens or I need to restart Roon to get it to begin.

The problem is intermittent but occurs frequently especially when I initially start up & than scroll through albums.
It doesn’t happen at start up but a little later when I’m using the Ipad to scroll.
No other app is running on the T530 at the time and utilization is below 2% ( disk & CPU ).
I am not exactly sure when this problem started but it seemed to start after the last few updates to Roon.

Hi @George_Walsh — Thank you for the report and sharing your observations with us, the feedback is appreciated!

Moving forward, may I very kindly ask you to please provide the following information:

  1. Since noticing this behavior with the iPad have you tried reinstalling the application on it?

  2. During your troubleshooting, have you tried (temporarily) hosting your Roon core on another device to determine if the same behavior is present while using the iPad to control Roon?

-Eric

Erik,
I deleted the Roon App & re-installed it on my iPad.
The problem still occurred.
It still seems to occur shortly after the app is opened regardless of what function I’m using.
It doesn’t seem to happen when the app has been opened for awhile but I’d have to try it for a longer time
to really verify this.
I have another instance of Roon on an Ethernet connected Windows desktop that I rarely use. ( Test System but at the 234 level as well )
I noticed that soon after I started Roon the same problem occurred. I wasn’t able to make it re-occur by scrolling
through the albums or by restarting Roon a few times.
I than tried playing music with no other Roon’s running and it didn’t fail in several hours of playing.

Switching the Roon Core would be fairly difficult since the Laptop is also the Output and it is USB connected to
a Wyred 4 Sound DSD 2v2 SE DAC in an equipment cabinet with all the other components. I have no other Windows Laptops but I do have several powerful MacBook Pros that I could install Roon on & use but I’m not
sure how helpful that would be if it Windows code related.
I could probably turn my Roon Desktop test system, also running Windows 10 PRO, into a core for a test but it would only be able to play through the Sound card not a DAC if that matters. Also not sure what the License situation would be - can I just leave the Laptop turned off and change the Desktop to a core?

Hi @George_Walsh ----- Thank you for the follow up and providing the requested information. Both are very appreciated!

Moving forward, you mentioned the following in your follow up:

I could probably turn my Roon Desktop test system, also running Windows 10 PRO, into a core for a test but it would only be able to play through the Sound card not a DAC if that matters. Also not sure what the License situation would be - can I just leave the Laptop turned off and change the Desktop to a core?

I would agree, that the mentioned desktop (Win10 Pro) is the ideal candidate for the proposed test. No worries about where the audio is streaming through/from, as we are just looking to confirm weather this stopping behavior occurs with Roon being hosted on another device. In preparation to conduct this test I would recommend the following:

  • Before ANYTHING – Make a backup of your Roon database and then power down the Lenovo T530 completely.

  • Close down Roon on any active remotes.

  • Bring up the “Roon Desktop test system” and follow the instruction found here.

  • Once the new system is configured, bring your Roon remotes back online and confirm if you experience the same behavior.

-Eric

Erik,
I turned my Desktop Windows 10 PRO system ( at exactly the same upgrade level ) as my T530 laptop into a core server. I tried for about 5 hours and could not get it to fail.
The Desktop system is a high performance I7 system with 16GB of memory & Radon Video & SSD cached 2 TB HD storage. The memory , CPU, & disk performance was about the same as the T530 ( less than 2% ).
The Library was smaller ( about 1/2 the size ) and it was connected directly to the same router as the T530.

At this point I’m not sure what I feel about the problem - It appears that the T530 has more than enough performance to be a music server but it has this problem. In addition I’ve had to use Group Policy edits to disable defender, update download, and automatic maintenance or the play stutters when they startup. Roon seems to be very sensitive to these scenarios since the last few Roon version & Windows 10 updates.

I wonder if I’m better served by moving to a MAC laptop ( which doesn’t have these maintenance problems ) ? or should I continue to explore a solution to these problems ?
I’ve tried several music server SW solutions and I love the sound & usability of ROON but these problems are beginning to make me question the viability of this direction.
I really appreciate your support and look forward to your recommendation on next problem solving steps or move to a MAC platform.
Thanks,
George

Erik,
Some further information on this problem.
Since the Desktop didn’t fail after additional trial hours with the problem I switched back to the T530 laptop.
To change back the core I actually went through a complete re-install. I deleted the Roon App including the library.
I downloaded the app again, created a new library, a fresh backup & redid the settings - aka a completely new install. The library reduced to 8000 tracks from 16000 since I didn’t scan the files on the HD only those on the SSD.
Everything worked fine until I restarted the Roon app on the ipad !!
The play stopped as soon as the app came up asking me to find the core since it had moved from the desktop.
I hit the play button on the T530 and proceeded to switch to the core on the T530. Almost immediately it failed again
and proceeded to fail multiple times over the next 20 minutes. It seems especially sensitive to fail soon after the app is started but does fail scrolling through albums later. Not sure what to try at this point ?

Erik -
I thought at this point that I would see how a core running on a MacBook Pro would work.
I used a 13" MacBookPRO Retina late 2013 with an i5 & 8 GB & all SSD storage.
The install, library etc was a breeze and the install used all the same non PC hardware & cables to play.
I tried for several hours and could NOT make it fail controlling from the iPad.
Unfortunately, I can not play DSD directly only using DoP !! and no DSD 256 just DSD 256 down-clocked to 128.
It looks like the OSX ( at the latest level ) core audio driver & ROON doesn’t support DSD direct.
I have quite a number of DSD albums so this is a show stopper for me - I need to do more research on solutions here - but it’s back to the T530 for now. - HELP !!

Hi @George_Walsh ---- Thank you for touching base with me and providing the observations you have made during your testing. The feedback and insight is very appreciated!

Moving forward, I would like to have our tech’s take a look at your Roon remote logs from the iPad to see if we can identify what is causing you to experience this behavior. I will be contacting you shortly via PM with instructions.

-Eric

Erik,
OK thanks ! What is PM ?
Just a bit more info on testing.
I played Roon music for several hours on Sunday using even DSD 256 albums with no Roon control started and everything worked perfectly- no skips , stops, stutters etc.
I tried switching the core T530 to wi- if instead of using Ethernet and it still failed.
The failure definitely occurs most frequently when I start up the app on my ipad and do something in Roon like scroll albums, look at settings etc.
Since Roon drops out of play I’m hoping that a log, trace, etc could find the trigger. I have plenty of resource available on the T530 and iPad to do tracing, log, etc

Hi @George_Walsh ---- PM stands for “private message”. The one that I sent you can be found here.

-Eric