Core lost connection to remotes

Just tried FING.Strange thing is that I seem to have 2 routers with almost the same name different IP adresses which also have a red flag at the end and
My computer with Roon on it is also listed. The n I have a “generic”. Is that roon? Should Roon be listed?

Thanks for the follow up @Jonas_Sjodin, the feedback is appreciated!

Moving forward, can you confirm if you do in fact have two routers currently running in your setup? I have seen remote connectivity issues in the past that occurred because two routers were present in the user’s network topology and had been configured wrong.

Furthermore, as asked in my previous posts (#1 and #2) having the details of your our network configuration/topology and insight into networking hardware you are currently making use of, will greatly help troubleshooting this behavior.


1 Like

Fing Says I do, but I dont. I have one router. Fing lists two. When I scan, one router
lists 8 services, the other one 0. could it be my neighbours? He´s not living there but his things are there.
Not sure what you mean with topology and configuration. In the basement I have my musicroom with the asus having roon core installed. Its wired to theTechnicolor router which is upstairs. To the Technicolor is also my Buffalo LS 220 NAS connected by Ethernet, and Bluesund Soundbar also wired. I have 4 phones and Ipad/ Samsung galaxy which uses the wifi. It works on all of them.
Technicolor is Router Swedens biggest internetprovider ( Telia) delivers.

Telia Technicolor router IP
Bufflalo LinkStation 220 NAS wired IP
My Computer ASUS wired
Pulse Soundbar wired
Samsung 7 series TV wired
Apple TV wired
Ipad wifi
Galaxy Tab wifi

Generic (Iphone??)
Then there´s the other Telia Technicolor router neighbour???

It could be that both routers are giving out ip addresses in the same subnet but are unaware of each other and some devices are getting a gateway and dns settings that are different from others.


Thanks @wizardofoz. Gonna do more investigating during the weekend. Strange, I restarted roon for the umpteenth time, and suddenly the roonremote found my computer and tried to connect to the core. But “connection failed”. tried maybe 6 - 8 times but failed. Now two hours later it´s back to as it were.

Any ideas,@support, @Eric?

Again, this morning. After turning off roon core, when I start it again my Roon remote sees the core and tries to connect for minutes but fails. I exit the remote and enter a minute later and now the remote cant see the core.

For troubleshooting purposes can you simplify everything, core into a basic network switch connected to your router, do remotes connect ok?

My remotes connects fine to the router but not to the core. Core is wired to the router.

Can you set up another Wired remote to see if the situation exists if everything is wired.

I have a laptop. Could that be used as remote? Just install roon remote on it?

Yes. Just install Roon and during installation tell it to be a remote and connect to a Core.

Hi @Jonas_Sjodin ---- Thank you for the continued feedback and more importantly, thank you for your patience.

Continuing forward, I agree with the test proposed by @Ratbert as it would be good to see how a hardwired Roon remote responds on your network. The test will provide insight into if this is an issues with the Wifi OR if there is a more general networking problem occurring. Looking forward to hearing your results.

Additionally, I would also be curious to see if you are able to ping the core machine successfully from your iPad when it is struggling to either connect/find the Roon core. Please see below for instructions:

  1. Download “Network Ping Lite” from the Apple app store.

  2. After downloading “Network Ping Lite” open the app on your iPad and you will see the following:


  1. Change the address in the “IP Address to ping” section to “” (i.e your core machine) and press the “Start” button. Let this run for 30 seconds to 1 minute, then press “Stop”.

  2. Take a screenshot of the results and share them “here”.


Yeah, these problems can be a pain. My laptop got very slow as a remote a couple of weeks ago and sometimes would not find core from my office. I deleted a couple of the latest updates [ Adobe Security]…used the Intel driver updater someone had put up here. It updated Wifi adapter plus graphics…Now all good. Happy lucky me.

Tried the wired remote. Did not work. Cant find the core. Shutting off/turning on the core leads to the remote trying to connect but failing.

Were all firewalls and antivirus off on the wired remote and the Roon core? I would also take a look and see if a Windows update happened around the same time as the lost connection. If so, you might roll that update back and see if it makes a different. I’ve known updates to mess up hardware network drivers.

Thanks @Rugby. Just had a friend over who knows his stuff. It seems as if my Network had changed to public from private. Also the Windows Firewall was active. That combination made it impossible for my remotes to connect. He changed the network to private with firewall on. Works like a charm​:man_dancing:t3::champagne:

Exceellent, you owe that friend a beer! The change from private to public can also happen with a Windows update.

1 Like