Core not Authorizing

From the core or also from the controller or output? I just realized that I’ve been focusing only on the core.

I would add both, just to be on the safe side.

Once I updated the Core to build 511 it began working. So, must have been an issue with 505.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Core Machine (Operating system/System info/Roon build number)

1.7 build 511 Ubuntu 16.04.3 running on ESX 6.5

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

All wifi: Procurve 6400cl backbone, Procurve 2900 switch, Sophos UTM 9.506-2 firewall and WAP

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Raspberry PI player

Description Of Issue
Repeat of issue that I thought was solved, but am getting the same behavior after restarting the server: Core not Authorizing

“Error retrieving account information” under Settings/Account
Doesnt see Tidal and Qobuz ( “Error loading page”).

Hello @John_Gore,

Have you made any changes recently from when Roon was working vs now? Any changes to your firewall?

If you temporarily try authorizing another PC as the Core (preferably running Windows or MacOS), does that work as expected?

do have 2 cores on the VM., A second one left over from trying to debug last time. I did try and switch to the other, but it wouldnt respond when I tried unauthorizing the first. The only thing that changed was that my VMs rebooted due to a power outage and I think I accidentally started the second one instead of the first. I did have Plex running on my NAS, but stopped it.

Subsequently, I upgraded the firewall but that didnt change things.

Odd thing was that the first time this happened, it cleared over the week that I left it alone. I attributed this to the core upgrading from 505 to 511. But now I dont think that was the answer.

I still have opened on the firewall rules to allow any traffic to the core. And turned off IPS. Ive looked for blocked packets and dont see any. Also used fiddler on my PC when connecting as the controller and see it getting info from a few of the Roon servers.

Main symptom is going to Settings/Account and seeing Error retrieving account information. Also unable to get to Tidal or Qobuz even though I can sign in.

Hello @John_Gore,

If you try installing Roon outside of the VM and on the Ubuntu using our Linux Install Guide, does Roon behave as expected there?

Sometimes VMs need special configuration to work properly and I want to verify if the VM environment is part of the issue.

I dont have a spare computer around. Could I install on a USB stick? I should be able to get the server to boot from that.

The core has been running on a VM for more than a year without issues until this started and I havent upgraded the VM environment.

HI @John_Gore,

I am not certain if you can install Roon on a USB drive, I have not tried this yet or seen reports of other successfully doing this. Is there no way to use Ubuntu outside the VM? Perhaps if you have a friend or family member come by with another PC and try logging in there (on your current network)? That should help clarify if the VM or the Network is factoring into this issue.

Now it is working. Similar to last time where it resolved after some days. I dont see that anything changed - still running the same build version, and I didn’t change the network or the VM.

Any idea why it breaks and then takes a few days to recover?

Hi @John_Gore,

That I am not certain of, but testing on a standard OS (outside of a VM) would help clarify if this behavior is due to the VM or something else on the network. It seems to be environmental, maybe you’re rebooting one specific device to get out of this state?

My power went off and Im having a similar issue again. However, it is only with Tidal now. The new release shows a bit more info on the error. I got a Tidal login prompt when trying to access a Tidal song, logged in (confirmed the info by logging in via web), and the error is:

There was an unexpected error, please check your account details (MissingMethod)

Hi @John_Gore,

This error message indicates that your Roon Remote version is out of date. I would suggest updating the Roon Remote/Client to the newest Roon build (v 528) and check that you are on this version via the Roon Settings -> About tab.

OK. Did that and Im back to the same error. I authorized my laptop as core and it works. When I tried going back to use the VM server, the same errors returned - unable to unauthorize my laptop and unable to confirm my account

Hi @John_Gore,

Since the laptop is working as expected in this case, and this issue affects just the VM Server, you should take a look into your VM settings or try running Roon outside the VM as I previously mentioned:

Since VMs can contain many settings, it is hard to say where exactly things are going wrong here. Please try running Roon outside the VM.

Hi both,
I had a very similar issue just yesterday, my laptop worked as it was the first setup for a core. Then I wished to have a separate machine/core in the apartment, but I was not able to activate/authorize the license on this 2nd machine which was available from my account. The error message was “network error”.
I read your threat, but the hint with the firewall (also in others) didn’t make sense to me, but tried to configure the same IP address as the laptop had before. And as this didn’t work out (so having assured it’s not a firewall issue) I got to the point, it’s probably a DNS issue.
YEPP it was.
So when enabling the DCHP with the new core, the hostname was properly registered in the DNS and all worked fine - both in the meantime …
So the packets sent back from your roon host in the internet via firewall were not properly sent to the new core, till the hostname was properly registered.

Cheers,
Alexander

1 Like

2 posts were split to a new topic: Roon Account - Error retrieving account information