Core Not Showing Airplay Endpoints and Constantly Losing Connection. Home Assistant conflict? (ref#2KSA16)

What best describes your playback issue?

· Music stops playing mid-track

Is there a specific error message you see? If so, please select from the following options:

· Other

Please try to reboot your Roon Server and check to see if this helps.

· Rebooting my Server had no effect, the issue remains

Please try to reboot and unplug/replug in your affected audio device and check to see if this helps.

· Rebooting and unplugging/replugging my audio device, the issue remains

Please open your Roon Remote and select the "System Output" Zone and try to play to it. Do you encounter any playback errors with this Zone?

· I don't have a System Output available, but I'd like to keep troubleshooting

Please try fully rebooting your network equipment

· No, I'm still having trouble

An issue with playback on System Output and another zone often indicates a network security problem. *Check your firewall(s)* to ensure that *Roon*, *RoonServer *and *RAATServer* are allowed to properly communicate

· I'm still having problems / This isn't relevant to me

Does the issue happen with local library music, streaming service music, or both?

· Both local and streaming content are affected

Please try playing content of a lower sample rate (44.1kHz or 48kHz). Do you still have the same issue?

· No, lower sample rates are still affected

What is the model/manufacturer of the affected audio device(s) and the connection type?

· All

Describe the issue

Since updating to the latest build 1432 today, the core no longer shows any airplay endpoints and the core is constantly losing connection every couple minutes.

If I play music to a zone, the music will suddenly stop and I will see the message “waiting for your roon server” when it finally reloads, I can no longer play any music. It does not react to pressing play. Even if nothing is playing and I leave Roon Remote up it will eventually lose connection and give the same message.

I’ve tried restarting Roon, reinstalling Roon and also moving to early access build 1431 with the same result. It was working perfectly prior to the update.

Describe your network setup

RAAT endpoints are all hardwired and Sonos a mix of wireless and hardwired.

I’ve found that if I shut down Home Assistant and start Roon all Airplay endpoint appear in roon again, and as Airplay2 now. Playback seems to work without the constant interruptions and core reloading messages every couple minutes.

The problem is I need to use Home Assistant and everything worked fine before this Roon update with Airplay 2 compatibility.

I’ve tried disabling the Roon integration and several other so far within Home Assistant, but haven’t been able to find the incompality. So i don’t know where the issue lies exactly. Home Assistant needs to be completely off for Roon to work.

FYI I run Home Assistant in a VM on the same Windows machine as Roon. The VMs are bridged to a separate network adapter than what Roon uses. I seem to have no issue running a dietpi VM at the same time as Roon.

I’m using Home Assistant and Roon, and have no issues using them simultaneously. The Home Assistant extension has been installed in Roon. I’m streaming to Yamaha MusicCast 20 with the new Airplay 2 functionality in Roon.
I’m afraid I can’t be of much help.

Appreciate the feedback. I’ve tested over and over and as soon as I boot up Home Assistant, Roon starts to lose its connection. Become unresponsive and no longer sees airplay devices.

I’ve tried disabling any HA integrations that have to do with Roon, airplay devices, etc… but no help. I’ve also tried binding to a dedicated network adapter for VMs as well as the host where Roon is.

Again all worked fine before this latest update.

I’ve got Roon stable again. I’m really not sure what is driving the issues with the latest update. I ended up bridging the VMs to my main network adapter then had to disable all other interfaces and it seems to have cured the stability and discover issues. None of the other network interfaces had IPs assigned or were disconnected. Also why would the issues only occur when my Home Assistant VM was running and on a different interface?

Funny enough, This is how I had things setup before, but I after a previous update many months I was dealing with intermittent Roon issues with music stopping and the cure was to bridge my VM network connections to an separate interface and all smoothed out.

With this latest update I’ve had to revert back. But the symptoms this weekend were much worse, basically unusable. What is the cause of this?
Seems like some sort of network issue always seems to creep up with Roon, how do we make Roon less fickle? It is really the only software that seems to have networking issue creep every so often.

I’m running a similar setup like you, all separate VMs running on a (single nic) Windows Server 2022 Hyper-V server (Intel NUC). I haven’t experienced network issues in the two (nearly three) years I’ve been using Roon. roonserver, haos, dietpi and ips are all Linux based VMs. Home Assistant has been added to my setup January this year. We’re both running an unsupported Roon setup (VM), I’m afraid Roon Support will not come to the rescue.

thanks again for chiming in Dennis, glad all is running smoothly for you. It seems like a lot of people are dealing with discovery issues with this update. I’m actually just running Windows 11 on a nuc and a running a couple VMs. My Roon server install is the windows package however.

Most of the time I don’t use Airplay or Airplay 2, but I have never seen the Airplay compatible devices disappear. However, I probably wouldn’t notice when they did.
Also I’m running an EA version of Roon (build 1431), maybe that makes a difference.

Yes, agreed. Airplay devices are not my main concern, but one of the symptoms I was facing. Sometimes Sonos devices would not appear as well. Roon Ready endpoints always appeared, but the server itself was disappear every couple minutes so really nothing was usable.
Anyway, glad to have it working again. Just wish Roon networking wasn’t so fickle.

Update. I am still finding that I am getting the intermittent lost connection to the server and it takes a while for everything to reload again. Once reconnected, RAAT enpoints are available immediately, then Sonos, and it takes some time for Airplay devices to show up again.

Very frustrating.

One other symptom I’ve now noticed is that there are a few extensions that keep requiring me to click on “pair” again before they will start working. Sometimes if I click pair, it disappears for a few seconds and comes up again still says “pair”. Other times it will disappear for a few seconds and then return to normal operation.

Hi @Nicholas_Thio,

Thank you for your patience awaiting a response. We’ve been investigating this report alongside other Airplay-related symptoms and will share updates as available from our QA team.