Core not supporting ARC sky router U.K [Solved: McAfee Firewall]

Is this CIG? Please provide the model number. Thanks.

Sorry it’s this

English Electric 8 Switch Audio Grade 8 Port Gigabit Streaming Switch

Please note the port number was changed due to Roon guides from the original which was not any number Roon recognised. I have no idea what port my Roon core is using nor how to find out but the first time generated same error

Your Sky router has a port 55000 set up using UPnP. To check that this is correct, go to Roon Remote, Settings > Roon ARC.

Ok that is what I am now using I disabled pnp settings and re enabled as per guidance but no joy
Are there orpther settings in the router Mel
Nuts which may be different.

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
} Same error message

Please share a screenshot of the router’s UPnP page, and the Roon ARC setup page (as they are now.)

On thought I am using Google dns on the core pc would that impact?

No idea where 55002 came from. I did try it after I saw that but still error

There may be an issue here that I changed my pc dns in settings to use google dns settings

nope just changed back to oringal SKY dns and still error.
It looks like I wil have to give up but want to formally state how disappointed I am in that I cant talk virtually to anyone in depth (12 hours work on this going thruogh all yur guidance and only having some support from one moderator in your fourm once a day means i am not really getting anywhere. I guess i will have to accept for no readily apparent reason my system and sky set up doesnt work but I have t say your customer service doesnt either
extremely disappointed.

From the above screenshots your port numbers are different.

Set it on Roon on the settings. Either enable UPnP and remove any manual port forwarding. If it doesn’t work. Disable UPnP and put manual port forward in place. Should work.

Is everything connect to the switch you mention?

Try connecting the core direct to your primary router and see if that works.

I found my ISP one box router/switch worked instantly when trying to help others work out issues.

1 Like

Your ports are different here. But, I can see that you have corrected that since.

On the sky router, turn off UPnP like Lewis says. Change the port forward number to ‘55000’ (if not already). Reboot the router and your core, then try again.

In your last two screenshots, the port numbers are different. They need to be the same: in your Roon Core and in your port forwarding configuration on your Router. Fix that, then reboot your router, then your Roon Core (including the PC or device on which your Roon Core is installed).

A Roon Support guy would have to troubleshoot this with your help, just as other community members do. For most people, UPnP just ‘works’, or manual port forwarding just ‘works’. If this is not the case for you, then yes, it will take time and effort to get it working… from the person trying to help you and yourself.

Also, if you haven’t done so already, please read the full article here:

Yeah, I don’t think the DNS will be an issue. I use and no issues.

Just noticed. You appear to have 2 logins for Roon community. @Alister_Scott1 & @Alister_Scott.

Or are these two different people

If the same person, are you logged in to ARC with correct credentials

Yes I have two log ins but no probs with Roon with on,y one active subscription. I have followed all guidance .
Have to say the port number was bizarre as never seen that before and never input that number
Will try port forwarding but also will reboot router rather than just refresh for current settings

Ok I try this but the disabling of upnp is temporary as it automatically activates. I can’t actually change the port on my sky router advanced settings even the port forwarding doesn’t allow me to change port

Ok so I did a manual port forwarding
Rebutted and got error

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}


I also went to upnp page and have the correct port now

So still not working
Perplexed as nothing else seemingly to do. Macafee virus scanner surely can’t be the problem?

The core in in my lounge and the router in another room. Moving that is hazardous as router in my 3 year old play room. We can protect a router but not a pc.
Why would a switch be a block?