Core on Mac crashes when starting remote on iPhone

Core Machine (Operating system/System info/Roon build number)

10.14.6 Mac Mini 2,5GHz 16GB Ram. Roon build 537 and 555.
Plain simple setup with Core on Mac Mini and controlling with Remote on iPhone. No wifi audio.
USB (via Regen and Jitterbug) to Hegel H160 w builtin DAC

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
I can use the Core application on my Mac mini but every time i start the remote app on my iPhone (and other iPhones i have tried it on) it presents a black screen (on the iPhone) and crashes the Core app (Mac Mini).

Hi @Anti_Wendel,

Do you see any error messages when Roon crashes or get an error report? How exactly is it crashing, does the app exit or just music playback stops?

Can you please reproduce this issue and let me know the exact local time + date it occurs at? I can take a look at the diagnostics from your Core + iPhone.

When I start the ios remote app I get a black screen on the phone and the Core app crashes completely w Mac Os giving me a crash log dialog.
Just did it again
Time: 18;45 Stockholm, June 12

I can mail you the crash log

1 Like

Hi @Anti_Wendel,

I’ve sent you a private message on where you can send the logs. I’ve also just enabled diagnostics mode for your Core and what this does is automatically upload a log set to our servers for analysis.

Hi @Anti_Wendel,

I can confirm I received the crash log, but I’m not seeing your Roon Core communicating with our diagnostics servers. Can you please ensure the Roon app is opened?

Core app is running and playing music

1 Like

Hi @Anti_Wendel,

Thanks for letting me know, I can see the diagnostics report arrived. I believe this issue might be due to some problematic media, can you please move this track out of your watched folder directory and let me know if it stops the crashes? /Users/Shared/iTunes/iTunes Media/Music/Wevie Stonder/Kenyan Harry/01 Intro.mp3. Please do not delete the file, because if it is the one causing this behavior, I would like to request it for QA purposes.

Hi again
Removed the file and got both core (build 537) and remote to work together again.
But later when i tried to activate the remote again, core crashed again (11.55 on june 13)
I have emailed you the new crash log.
Needless to say i am terribly disappointed, I had high expectations (specially since you charge 120usd/year for this software).
But this reminds me more of beta-testing new software :frowning:

Hi @Anti_Wendel,

Sorry to hear that the issue is still the same after removing those files, having problematic media files, especially multiple is a rare issue that we would certainly like to look into an resolve, which is why I asked for the files to be kept until the end of troubleshooting.

The crash log is not too useful here, but what might be is the Roon logs. I am not seeing the diagnostics report be delivered any longer, perhaps your Core is turned off.

In any case, can you please manually send me your Mac logs? You can use these instructions to access them and you can email to the same location as before.

Thank you!

I left Roon Core running just playing music. It crashed last night without any user interaction. I have emailed you the log.
I am restarting Roon Core now and emailing you the roon logs also.

Hi @Anti_Wendel,

Thank you for sending the crash log. I believe I have found another problematic media file:

/Users/Shared/iTunes/iTunes Media/Music/Alan Parsons Project/Eye In The Sky/07 Psychobabble.mp3

Please move this file out of your watched directory as well (but do not delete). If this is the file Roon is getting stuck on, I would kindly request this at well at the end of the process.

Also, just a note, you can disable background and on-demand audio analysis under Roon Settings -> Library, just in case there are other problematic media files.

Hi again !
OK !
So I will remove also the new problematic file.
And turn off the audio analysis.
I will let you know if Roon Core/Remote stops crashing now.
But I really think that a 120usd/year software shouldn’t crash from file audio analysis…
Disappointed so far.
Much troubleshooting, crashes, restarts etc…

1 Like

Hi @Anti_Wendel,

Thanks for trying to remove the file, do let me know how it goes.

Sometimes corrupted files cause strange behavior in Roon, and of course we want to prevent such issues.

Once we have determined the files causing the issue, we can get them over to QA and they can file a ticket for the developers to hopefully mitigate similar issues with Roon in the future.

Didn’t you also receive the roon logs i emailed you ?
If not it’s probably because of the 30MB+ size of the file.
In that case, do you have any other way i can send the roon logs to you (i dont use dropbox) ?
Ok so now when i have turned audio analysis off everything seems to work.
Except that I can’t set audio volume with the remote (“volume control is fixed”).
What next ?

Hi @Anti_Wendel,

Yes, I received the log file from you, but none of the problematic media files. Can you please send these when you have a chance?

That’s fantastic news.

What kind of zone are you trying to control? You can specify the control type in the Device Setup tab for the zone (Roon Settings -> Audio -> Cogwheel next to zone -> Device Setup -> Volume Control`. I suspect you have “Fixed Volume” there, and if you want to control the volume from within Roon, you can use Device Volume or DSP Volume.

Ok I have emailed you the two tracks now.
Roon is still working, so it seems that the audio analysis was the cause of all the crashes.
What now ?

Hi @Anti_Wendel,

Thanks for sending the tracks over, I can confirm we received them.

I will sen the media files over to QA to look into this issue further and see if we can reproduce the behavior you encountered.

If we are able to reproduce in the lab, we’ll file a ticket with our dev team to try to make a change so that Roon does not crash when scanning these files.

That’s fantastic news! Glad to hear we could solve this issue, do let us know if you run into any further difficulties!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.