Core Server 1.7 crashes on start-up Windows 10

I’m just trying out Roon and the server crashes on start-up on my laptop

Windows 10 Home 1909 18363.476
Memory 4GB
Celeron® Dual-Core CPU T3500 @ 2.1 GHz

I looked through Windows Event Viewer and couldn’t see anything relevated.

Yes, I have now. Restarted, and got my Windows 10 absolutely up to date. It still crashes on start-up. I have Malware Bytes installed as well. Wondering if that’s the problem.

Are there any more logs I can find?

Hi @Gareth_Brown,

Would you kindly try the following and let us know if you’re still seeing issues?

  1. Download .NET Framework 4.8
  2. Download the latest graphics drivers from the manufacturer of your GPU (you won’t want to rely on Windows driver updates for this)


I’ve got .NET 4.8 already installed.


My graphics is pretty ancient, Mobile Intel Series 4 OpenGL but the driver is up to date.


Mentions OpenGL 3.0 extension support but not API support

Hi @Gareth_Brown,

Can I please request that you send us a copy of your Roon logs by using these instructions? The best way to get them over to us would be via a shared Dropbox / Google Drive link, but if you don’t have either service just let me know. Thanks!

Thanks I’ve got the logs, it’s roughly the same issue as:

12/16 20:15:35 Info: Starting Roon v1.7 (build 505) stable on windows
12/16 20:15:35 Debug: looking for *_old files in: C:\Users\Rose\AppData\Local\Roon\Application
12/16 20:15:35 Debug: looking for old numerical version dirs in: C:\Users\Rose\AppData\Local\Roon\Application
12/16 20:15:35 Trace: Checking if we are already running
12/16 20:15:35 Trace: Nope, we are the only one running
12/16 20:15:35 Info: Is 64 bit? True
12/16 20:15:36 Trace: [broo/imagecache] loaded 0 cache entries from C:\Users\Rose\AppData\Local\Roon\Cache\brooimages_1\index.db, current: 512mb / 0mb
12/16 20:15:37 Info: [stats] 4739mb Virtual, 27mb Physical, 1mb Managed, 334 Handles, 11 Threads
12/16 20:15:47 Info: Loading broo project: ui.broox
12/16 20:15:47 Trace: [realtime] fetching time from NTP server
12/16 20:15:47 Trace: [realtime] Got time from NTP: 16/12/2019 20:15:47 (3785516147592ms)
12/16 20:15:48 Trace: [realtime] Updated clock skew to -00:00:00.3807346 (-380.7346ms)
12/16 20:15:50 Error: Couldn't load WGL extension functions: System.ArgumentNullException: Value cannot be null.
Parameter name: ptr
   at System.Runtime.InteropServices.Marshal.GetDelegateForFunctionPointer(IntPtr ptr, Type t)
   at Broo.Engine.OpenGL.Wgl.LoadWglExtensions()
12/16 20:15:50 Warn: System.NullReferenceException: Object reference not set to an instance of an object.
   at Broo.Engine.OpenGL.Wgl.wglGetExtensionsStringARB(IntPtr hdc)
   at Broo.Engine.GlWindow.InitializeContexts()
   at Broo.Engine.GlWindow..ctor(OpenGlWindow glwin)
   at Broo.Engine.OpenGlWindow..ctor()
   at Broo.Engine.DeviceTarget..ctor(Window& window)
   at Broo.BrooLoader.Load(Boolean rendertrace, String brooxfile, String bindingsdllfile, String atlasname, Engine& engine, Window& window, LoadContext& loadcontext, String& err)
   at Sooloos.Application.Main(String[] argv)
12/16 20:15:52 Info: [stats] 4860mb Virtual, 45mb Physical, 1mb Managed, 504 Handles, 18 Threads
12/16 20:15:52 Info: [broker] starting 73242696-849d-421d-abeb-d9cab998be1f
12/16 20:15:54 Trace: [httpcache] loaded 0 cache entries from C:\Users\Rose\AppData\Local\Roon\Cache\httpcache_2.db, current: 0mb / 128mb
12/16 20:15:56 Debug: [broker/filebrowser/volumeattached] initial listing found drive mounted at C:\
12/16 20:15:57 Info: [broker/locations] adding storage location: Internet:Name=Internet Media:Id=e268f098-04c4-4e65-af3f-38ba3c3fcecb
12/16 20:15:57 Info: [broker/locations] media availability: Internet:Name=Internet Media:Id=e268f098-04c4-4e65-af3f-38ba3c3fcecb is online
12/16 20:15:57 Info: [broker/locations] adding storage location: MetadataService:Name=Metadata Service:Id=13769258-b70b-4243-b1d6-bd46e8257ba8
12/16 20:15:57 Info: [broker/locations] media availability: MetadataService:Name=Metadata Service:Id=13769258-b70b-4243-b1d6-bd46e8257ba8 is online
12/16 20:15:57 Info: [broker/locations] adding storage location: Offline:Name=Offline:Id=f1e4b43f-f643-47ba-b875-fd93b32a6006

I’ve tried looking for updated Intel drivers again, but I don’t think this machine will run it.

Hi @Gareth_Brown,

Can you please try running the Intel Driver Assistant if you haven’t already?

Done that, but it said no driver updates are available.

Hi @Gareth_Brown,

Thanks for checking the Intel Assistant. I would next like to set your old Roon installation aside to see if this allows the app to start properly, can you please give these instructions a try?

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Verify if a fresh database works as expected
  • Try restoring a backup of your Roon database

Okay, I’ll try that tonight, but this is the first time I’ve ran Roon on this laptop.

Hi, @Gareth_Brown, we released a new version of Roon. The latest version can be found here – . Please, install this build and see how it goes.



Thanks that’s a much more insightful error. I’ve given up using my old laptop for Roon, and ordered a better PC in the hope of giving Roon another shot in the New Year.

Hi @Gareth_Brown,

The behavior here is still the same even if you press the “OK” button, correct?

Do let us know if Roon works as expected on the new PC, Happy New Year to you as well!

If you click Okay, Roon still crashes out on the old computer. Thanks for the update.

I’ve got my new PC installed and Roon boots up. Is there any chance of getting trial extension so I can give Roon another try?

Hi @Gareth_Brown,

I will follow up via private message, thanks!

Hi Roon people, just FYI the workaround for this issue (which affects all users of Windows 10 version 1903 who use Remote Desktop) is to disable WDDM in the group policy. The workaround is described here:

tl;dr Gpedit.msc: Computer Configuration->Administrative Templates->Windows Components->Remote Desktop Services->Remote Desktop Session Host->Remote Session Environment -> Use WDDM graphics display driver for Remote Desktop Connections -> DISABLE

Alternatively, it would be good if Roon could mayber not require OpenGL, so it could be used over remote desktop?


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.