Core/server access to local audio on Mac

Core Machine (Operating system/System info/Roon build number)
macOS 10.15.4, latest roon server install.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

DAC connected via optical to Mac Built In output, CXN2 via wired network

Description Of Issue

I cannot see the local audio devices on roon running on the mac. I can see the CXN and this works correctly.

I initially installed roon with both core and remote on the mac, and this worked fine. However, to avoid the need to run the desktop, I am trying to setup so that the remote is on a different platform as per the configuration guidelines.
This seems a similar problem to that described for headless Windows installs.

Welcome to the forum. Did you “enable” the device.

Settings> Audio

Hello @Jon_B, and welcome to the community! Could you please:

  1. temporarily disable your firewall and AV and check “Settings>Audio” for the devices?
  2. Send us a screenshot of “Settings>Audio” so we can see what’s showing up?

I have ‘solved’ the problem after restarting a few things, and everything seems to be working just now.

The configuration I am trying to set up is:

  • core running on a mac in my office, with DAC connected to mac via the optical out
  • CXN2 running in the lounge
  • the mac and CNX are wired connections to the LAN/internet
  • windows surface laptop as the remot via wifi, although I would probably also use the roon app on the mac as well in the office

I think the problem may be related to trying to use the laptop when the mac sleeps. This seems to partially connect, in that I can see the filesystem, but no audio outputs are shown. I will continue to experiment to see if I can isolate the problem.

Should the laptop be able to wake the core, or do I need to either stop the mac sleeping or wake it before connecting?



Hello @Jon_B,

For best results with Roon we recommend having your core awake and accessible to support connection from your remote. In this situation, I’d recommend adjusting your power and sleep settings on the core or accessing said core through other means to turn it on before using Roon.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.