Core suddenly won't connect my iPad

I’ve been running Roon core on my iMac about 3 months with my iPad pro. Couple times lately it couldn’t find the iPad but did after reboot. Today no matter how many reboots, nothing.
Roon 1.5 64 bit
Mac OS High Sierra Version 10.13.4
Music files stored on external drive

Hey @Fran_Hearley — Thanks for reaching out to us!

Please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

So we can gain some additional insight into this behavior, please see the following:

  • Is there any active antivirus or firewall on the Core machine? If so does disabling yield any different results?
  • Have you tried power cycling your networking hardware?
  • Are other remote devices able to connect?
  • If you use an app like Fing that scans the network, are you able to see the iMac Core from the iPad?


I don’t have any other remote devices. They see each other, and both show to be enabling my iPad, but it just never happens.

Thanks, @Fran_Hearley.

Can I get some more info about your networking setup?

Have you confirmed if there is a firewall enabled on the Core? If so, try temporarily disabling it and let me know if there’s a change.


Hey Dylan,
The firewall was set to allow connections to Roon. When I turned it off there was no change. Still no audio devices found…

Thanks for giving that a try, @Fran_Hearley.

So I can better understand how everything is communicating, can you please describe your network topology?

  • What networking hardware is in use (router, switches, etc)?
  • How is the Core machine connected to the network?
  • What devices are connected to the network, and how are they connected?

Just to confirm, by this you mean that the iPad wasn’t able to find the Core, correct? Or was the iPad connected but not seeing any audio devices in Settings > Audio?


No separate router, Century link fiber optic 100 mbps modem.
connected to the network by wifi
The iPad IS connected, but neither it nor the core sees any audio devices.

Thanks for the info, @Fran_Hearley!

What type of endpoints are you using? How are they connected?

When you go to Settings > Audio, do you see any endpoints, or is this screen blank?

Do you have exceptions in place for RAATServer as well?

If you connect the Core machine to the network via an Ethernet cable is there any difference in behavior?


Ethernet is not an option. Same problem this evening. It was working and there were 2 loud beeps and it was gone, can’t get it back. If you don’t have any more ideas I’m just going to cancel my Roon and get a refund…

Hey @Fran_Hearley,

First, I want to apologize for the difficulties here. I’m confident that we can troubleshoot this together.

A little more information about what exactly you’re experiencing should allow the team and I to have some greater insight into what is happening.

  • How long was this working before it stopped working? Do the beeps happen every time this behavior occurs?
  • What kind of content were you playing when this behavior occurred?
  • What was the endpoint that you were playing to here? Does this only occur for this one endpoint?

Can you confirm that you have firewall exceptions in place for RAATServer?

Can you share a screenshot of what you’re seeing in Settings > Audio?

Thank you,

It had played about 20 minutes before the beeps. Flac files from HD Tracks.
First time for the beeps. My only endpoint is my iPad Pro. Rechecked the firewall.


Thanks @Fran_Hearley!

Based on the troubleshooting we’ve done, it definitely sounds like there may be some networking difficulties at play. I know it’s not ideal, but even if we could temporarily have the Core connected via Ethernet we should be able to better understand exactly where this behavior is stemming from.

Are there any patterns you’ve noticed when this behavior occurs? Is it during a certain time of day? When other devices are in use on the network?

Additionally, is this behavior you’re able to replicate with the same tracks? If you were to attempt to play the same media that it stopped at previously is there any difference in behavior, or does it happen every time.


Due to the way century link installed the new modem, there’s no way I can connect the core by Ethernet. Did I mention that it’s been running fine for 3 months prior to rhis?
I only use Roon for a couple hours every night. Couple weeks ago it started not finding any audio zones, but would work every time after reboot. This last weekend it wouldn’t work at all. It did come back the other night, but quit after the beeps.
I cannot replicate the beeping scenario because it only happened once and Roon has not worked since. I may have said this before, but the core does see my iPad and appears to be “enabling…”. It just never plays.
Getting extremely frustrated at this point…

Hey @Fran_Hearley,

Thanks for the details, and apologies again for the frustration here.

First, I’d like to propose a test. Can you play Roon to the output of the Mac Core machine? When you do so, does the same behavior occur, or is it just the iPad?

On the Mac Core, I’d also like to suggest trying the following:

  • Make a backup
  • Shut down your Roon Core
  • Locate your Roon database according to these instructions
  • Rename the entire RAATServer folder to RAATServer_Old
  • Relaunch Roon

After this, let me know if there is any change in behavior.

Finally, I’d like to recommend reinstalling the Roon Remote app on the iPad. Does this yield any changes for you?