Core that previously ran Roon now shows Open GL fatal error

Roon Core Machine

MacBook Pro 2014 (A1502) 2.6GHz i5, 8GB RAM

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library


Description of Issue

I have been struggling with a series of issues keeping Roon up and running on a dedicated Core (internal SSD failure, external music HDD failure and more), but finally got those issues resolved, and everything seemed to be OK. Then I upgraded the OS to Big Sur 11.6.5. When I tried to run Roon I received this error message:

Open GL 3.0 or higher is required. The video drivers on this system do not support Open GL 3.0

This exact setup (but for OS upgrade) was running Roon an hour before.

How do I get back to listening to music?

You can check online to see if the video card in your machine has a newer driver to download. The OS update could have installed a different driver for the card.

Thanks, but Apple seems not to allow that:

Is Roon incompatible with Big Sur? If so, I can’t be the first person to experience this. Am I going to have to figure out a way to roll back my OS version, and then never upgrade again?

It doesn’t work like that on macOS. The drivers are baked into the operating system. They are not user-installable or upgradeable.

Ok, sorry. Obviously I’m not mac literate. If the driver is in fact Open GL 3 or higher and Roon software can’t detect that then they have some work to do.

1 Like

Are you running Big Sur in a VM?

No. It is as simple and clean an install as I know how to do.

Hi @John_Steinberg,

Thank you for bringing this issue to our attention, and I’m sorry to hear you’ve been without Roon.

Are you using a display adapter in your setup? If so, try launching Roon without the adapter. It’s possible the adapter isn’t exposing its OpenGL settings correctly.

You’ll likely experience more stable performance (and extend your device’s compatibility with Roon) if you upgrade to Catalina instead of Big Sur for this Core. Your 2014 MacBook should also be able to load OS Catalina without issue, according to Apple’s listed requiments.

We’d be happy to answer any questions you might have.

Thanks for responding. No, I am not using any external monitor or adapter – just the screen of the MBP.

The MBP insists that it is fully up to date, and is not offering the option of further upgrading the OS.

Also, isn’t Catalina (10.15) a downgrade from Big Sur (11.0)?

Never mind. I just figured out what the problem was.

I was running the MBP in safe mode. When I rebooted normally, Roon loaded properly.

Thanks to everyone who tried to help!


Hi @John_Steinberg,

Glad to hear it’s been resolved!

While it’s a more recent OS, the OpenGL implementation for Big Sur isn’t (generally) as reliable as it is with Catalina. Regardless, I’m thrilled to hear Roon is up and running. Please reach out in a new thread if anything else comes up.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.