Core will not update to v1.3 build 274 on QNAP NAS [RESOLVED]

@support Usually updating my core (within the Roon software - setting) is smooth and fast. Last Friday I updated the Roon Server app to the one that is available within the QNAP App Centre “Roon Server 2017-10-03”; with no issues. When opening the Roon software on an endpoint it indicated that there were updates so I proceed to the setting area within the Roon software. Roon updated from v1.3 build 269 to v1.3 build 274 on my PC but the updating of the core resulted in this error message: ‘’There was an error checking for an update.’’. This issue is only affecting my core not the endpoints. I checked the QNAP App Centre on my NAS and the Roon App showed no update; still the one installed on Friday. Any ideas on how to fix this?

As a footnote, I am still able to connect to the core and play music from the endpoint.

I have plopped this into the NAS area… maybe @crieke Chris can help too

Hi @June_Coll,
If you applying an update within Roon there won’t any change to the version number in the QNAP AppCenter. That. is as expected so far. But of course the error message in Roon is not expected.
Can you still access the Roon webpanel in your qnap admistration? If so, browse to advanced and click the “Reinstall” button on the right side of the window. This should re-download the latest available RoonServer.

i know this is about the update to a Qnap, but I go the same error while trying the update my NUC with ROCK on it, I just rebooted the NUC and let it restart the update and it worked the second time. Don’t know if that might help you. ??

@crieke @wizardofoz @bearFNF @support - Thank you Chris. I did as you instructed and it worked!

I changed my Roon Server to support the official QNAP AppCenter version when released. I just received the notice to update my clients (Mac & RPi) and noticed that in the about window RoonCore shows an error ‘There was an error checking for update’ ? I never had an issue with the previous install before the AppCenter release. Any ideas?

Not sure if it’s related but also if I try an ‘open’ Roon on my QNAP I get the error :

Not Found

The requested URL /apps/RoonServer/ was not found on this server.

Apache Server at Port 443

Hi @Mike_Ormerod,
Just wondering: Were you able to access the Roon web administration panel before you performed the update of the core?

To be honest I can’t remeber if I ever tried. But I’ve certainly not had any issues updating before.

If you can’t access the webpanel, please try to reinstall it in the QNAP AppCenter (Remove and Install).
Your current database will be automatically picked up.

@crieke - I removed & reinstalled via the AppCenter. Roon is now showing that it has the latest version (via the client about info) but if I try to ‘Open’ Roon on the QNAP I still get the above Apache error with regards to the RoonServer not being found on 443.

This was cool! I hadn’t even noticed that the QNAP App had been updated, to have a webgui.
My update to Roon Core/Server build 274 went without incident yesterday and when i visited my QNAPs GUI today i performed the qpgk-update as requeste by QNAP OS. This too was quick and incident-free.
Great job @crieke!

Edit: Does someone know why some browsers Capitalize some Letters Spontaneously?

Had the same issue - and reinstalling the Roon Server from the Roon Webpanel on QNAP did the trick. Thanks Chris.