Could not downgrade ROCK 2.0 to 1.8 Legacy and database 2.0 problems [Investigating]

Roon Core Machine

NUC8i5, 32GB, 256GB NVME

Description of Issue

  1. I have tried to install a fresh ROCK install from a USB installer on my spare NUC, an NUC10i5 and an empty 480GB NVME which installed without any hitch. I had Remote 2.0 removed from my iPad and have Remote 1.8 Legacy installed.

  2. I then copied ffmpeg to Codecs folder. This gave me build 571.

  3. Then I stopped Roon Server Software.

  4. I then created a “branches” folder, downloaded “roon_1-8” file, copied that file to “branches” folder and renamed the file to “roon”

  5. Then I click “Reinstall” the OS

  6. This is where I am confused. The process took only a few seconds.

  7. After I click the OK button, the NUC restarted and I am back with build 571.

  8. Thinking that this whole thing might only work if I already had 2.0 version, I opened remote and updated the core.

  9. The update gave me version 2.0 build 1128

  1. I tried step 3-5 above with the Roon 2.0 build 1128, but it I am still back with build Roon 2.0 build 1128. I could not downgrade to version 1.8 production.

Next thing, I retried step 1-10 above on my main ROCK, a NUC8i5, which is running Roon 2.0 build 1119 early access, but I could not downgrade to 1.8 either.

Finally I downloaded Remote 2.0 b1127 but could not connect to my main ROCK with the remote. I downloaded TestFlight and reinstalled Remote 2.0 b1119 and I could not connect to my Core. This is the first I have problem connecting to my Core, ever. Frustrated and now I want to listen to the music in my evening, I renamed the RoonServer folder and restarted my core in order to start over from an empty database. This time the remote could connect and I did a restore from my last backup from "2022 Sep21 07:04:28 Version 2.0 (build 1119).

After the backup is finished I relaunched the Server and after a few minutes I still could not connect to the remote to the core. Usually it only takes 1 minutes 40 seconds for the remote to connect from a restart.

I deleted the RoonServer folder and started a restore process again, this time using my “2022 Sep 8 02:01:20 Version 1.8 (build 1021)” backup. After the restore was completed, I relaunched and after a couple minutes I was asked to deauthorized my backup Core setup previously in step 1 above. Almost all went well, except that Metadata improver was paused and my hard disk scan only ran partially. Core restart fixed all that.

However, I am still back at the beginning. I wanted to downgrade to 1.8 and could not. Did I miss anything in my steps above? Please assist.

Thank you.

Hi, @Hogio_Setiawan, thank you for the detailed post. I am going to discuss that issue with our dev team and try to reproduce it locally.

Thanks!


Ivan

Dear Ivan,

I solved it. I made a mistake in downloading the roon-1.8 file by right-clicking when saving the file and ended up saving the file as an HTML file even though I did not choose an HTML when I saved it. Once I clicked and/or opened the link in a new tab, I saw a green download button and clicked it and could save the file. It is a small file. Only 12byte. The one I had was 44Kb.

I am now at Roon 1.8 (build 1126) production1x. However, I still see a notification “An update is ready to be downloaded. Click here to install.”

I restarted my ROCK twice and that update notification still shows up. I already deleted FlightTest and Remote 2.0 previously.

Why is it? Is there a new version of 1.8 Legacy? This is the first time in a long time when I am afraid to click an update in Roon. I am staying with Legacy for now.

Regarding the problems with the previous backup, I don’t worry about it anymore. It is only a few days difference. I am okay.

I stopped Roon Server and clicked Reinstall again to see if I could get rid of that update notification. No change.

@Hogio_Setiawan, you were in Early Access testing for 2.0? If that’s the case then the server is trying to move you back to earlyaccess. We’ll be removing that rule today so this should just go away on its own.

Yes, all fixed. No more notification of update. I am all good for now.

Thank you.

1 Like

Sorry, I spoke too soon. I was able to downgrade my main ROCK NUC8 which is my main system.

But, this morning I tried to install ROCK Legacy to my NUC10 that I use as a spare. I am typing this as I am doing the process since I had tried it previously with no success.

I did a fresh install from USB installer, started from build 571. I copied roon file to the branches, click Reinstall and came back with build 571. I then connected the remote 1.8 Legacy to it and it prompt an update which I did.

However, after the update, I got Roon 2.0 b1128 production.

Trying to connect the remote to the core gave me a cycle of two screens without the ability to connect or login:


Then I tried what I have successfully did yesterday with my NUC8, I copied roon file to branches, stopped server, and click Reinstall, but still I get Roon 2.0 b1128.

This is with an empty database. Should I login to it first? But my Remote would not let me connect as the following screens show.

I have never login to this core. Do I need to login first for the downgrade to be possible?

I then reinstalled Remote 2.0 from PlayStore to connect and login to the Core on NUC10, while deauthorizing NUC8. Then I stopped the Server again and clicked Reinstall again. But, after the server is restarted I am still at Roon 2.0 build 1128.

Please assist again.

Thank you.

Amazingly, I am suffering the same problem. I thought I’d run 1.8 (Legacy) on my spare ROCK. However, I cannot get it to run/show 1.8 Legacy Build: 1126.

I’ve followed the same steps above.

I even thought that it might be the copy and paste issue (like I got on doing the codec file), so I dragged and copied the file and reinstalled the system again but, to no avail…

Even I’m stumped…

Followed the exact same path (including html file error) to downgrade my ROCK.
Pasted the right ‘roon’ file.
Content is ‘production1x’ , can someone confirm ?
Stopped core,
Asked reinstall,
and I’m still on version 2.
I cant update my remote (stuck to windows 7 … so to legacy version 1.8 …)

Tried several time, but looks like no music tonight …
Can anyone help with roon … or come by and sing a song for me ?

Maybe updater may check that all components can be upgraded before upgrading individual components. ie remote and server … This would make sense and avoid mess.

May I suggest ROON elabores a ‘upgrading’ procedure that eventually, and gracefully, upgrades or dowgrades components so that we can listen to music, as it’s expected from the licence cost ?

Or completely open the protocol so anyone could match it’s remote and server protocols with a few hacks ?

I’m also a victim of this unperfect downgrade process.
I’m unable to connect to my ROCK core after downgrading the OS as explained.
the roon file in the branches folder is filled with production1x bur my remote kee saying that my remote and my core are not in the same version.

What are we supposed to do to continue using Roon 1.8 ?

After reading that people had the opposite troubles as me (they cannot upgrade from 1.8 to 2.0) and that Roon found an issue on their server end and fixed that (see this link
Why did Roon spontaneously revert itself from Roon 2.0 to 1.8? [Fixed: Update Server Error, Update To v2.0 Using Migration FAQ] - #100), this morning I redid the process. I just stopped the core, click Reinstall and after a few minutes I see that I am at Roon 1.8 Legacy, which I wanted. So, something on Roon server must have changed from Friday and got fixed on Monday.

So, I am all good now.

Thank you.

1 Like

Tried with hope … but didn’t work for me.

Same result as before.

Does roon offers a win10 or 11 computer to serve as remote ?

How did you do it? Maybe some screen shots would help.

Hi !
Downloaded, renamed and copied roon file into a newly created branches folder on my Rock, as pictured here. Folder treeview on left, folder content in middle, and file content on the right pane.
Looks mostly ok to me …

Then, from the web access to Rock

I unconnected remote, stopped the ‘Roon Server Software’.
Once Stopped, I did ‘Reinstal’ the ‘Operating System’
Until it successfully … switch back to V 2.0 Build 1128 … :frowning:

Tried several times, but no much luck.
Did I oversee something ?

Your screenshots look fine to me. I don’t know what happened. Hopefully support might be able to look at your case and help you more.
When did you last try? If you tried it sometimes between Saturday and Monday it would not work since there was some issues with their server configuration.

I can only say that when I downgraded my Nucleus from 2.0 to 1.8 legacy the downgrade would not work (after many tries) until I left the remote connected.

The Roon migration FAQ states:

You will need to install the Roon 1.8 legacy app on a Roon Remote/iOS device first before being able to take the downgrade.

I assume that in order for the Roon server to know that you have done that the remote has to be connected as part of the downgrade process. At least, that’s what finally worked for me.

Stephen

Hi,
I did it a bit more than 23 seconds before sending the screenshot yersterday evening. It was my last attempt.

@Stephen : the first screenshot appears when restarting remote … Happy it worked for you !

Now I’d just love to use ARC when at work … but I need to access music @home . Maybe the answer would be a Win7 compatible remote ?

Hi Stephen,
sorry looks like coffee wasn’t strong enough this morning. Although this would blow my mind (having a remote interfering with a shut down core), I will try this when back at home.
Sorry for the misreading, badly needed a few coffees more obviously. I’ll keep you and everybody informed this evening.
Eric.

Thanks Stephen !

One has to keep the 1.8 remote connected before shuting down the server !
This should be IMHO emphasized in the Roon migration FAQ
It’s a bit counter intuitive for me to launch a remote before shuting down the srever … but it works.
Thanks again. You should be promoted Roon Support ! :slight_smile:

I’m so glad it worked for you too. I agree that:

  • it’s counter-intuitive; and

  • it really does need to be made clear in the Roon migration FAQ.

Stephen