CPUs known to be able to do HQP non-2s poly-sinc-xtr from RedBook to DSD512

There are only two or three CPUs known to be able to do non-2s poly-sinc-xtr from RedBook to DSD512. My i7 6950X and I’ve seen reports that i7 7980XE/(or 7960X) would be able to do it too. Not sure about AMD Threadripper 1950X.


Here is an i7 8700 [not a sonicTranporter mind] doing poly-sinc-xtr.


Is this RedBook to DSD512 or something else?

Yes red book to DSD512.



To continue the inquisition … :grin:

CUDA off ?

CUDA on.


1 Like

But looking at your GPU usage, it’s not helping anyway.

I had to clean install the latest GeForce drivers to get CUDA offloading to work and see GPU usage around 30% - but it didn’t help, it made things worse for reasons Jussi has explained before (CPU is faster in my case).

But it’s working for you with no GPU help it seems. Awesome.

Could be drivers, could be greyed Multicore DSP (auto setting) deciding parallelism isn’t efficient here.

I’ll try again with CUDA off. Think of my CPU as the little engine that could …

Edit: Nope. Still a bridge too far.

OK, great! Looks like i7-8700 is the least expensive CPU that can do it so far! Probably the increase of two extra cores compared to 7700 while keeping the high clocks helps. At just 65W TDP (and K model at 95W TDP) those can be still passive cooled as well.


I have built a few units with an i7-8700 (6 core). If anybody’s interested I can build one for them.

1 Like

For completeness,

Trying poly-sinc xtr with CUDA off gives stuttering as does multicore ticked rather than greyed.

So although in the screenshot it doesn’t appear as if the CUDA is doing a lot, whatever it is doing is making the difference.


Another conundrum.

Closed form is causing stuttering. Below is poly-sinc-xtr followed by closed form. Closed from seems to be using less CPU but I get stuttering.

Any ideas/suggestions @jussi_laako?


Your system is pretty much at full load already, since you have a CPU with HyperThreading (see in your screenshot, 6 cores with 12 logical processors). The load is for all logical processors, so 50% means all physical cores being 100%. You can click the “Open Resource Monitor” you have in the screenshot, and there take a look at CPU tab to see how cores are loaded, half of the logical processors are likely close to maximum load.

CUDA offload helps on closed-form quite nicely. But it doesn’t seem to be operational because your GPU load is just 3%. You may need to download and install latest Nvidia display drivers to get it enabled:

1 Like

Yep, I mentioned the same before.

As I mentioned, doing a clean install of the latest driver (it gives you that option of a clean install when you install) made my GPU usage go from 1% (i.e. nothing) to 30-50% (i.e. something)

My Dell’s app centre said I’d had the latest GeForce drivers but it wasn’t the case. Best to get the latest from the GeForce site.

I’m now a semi-expert after making nearly every mistake possible :grin:

1 Like

Best way to learn!

1 Like

Unreal this is.

I have upgraded to the latest driver and now as suspected closed form works and GPU use is much higher, HOWEVER poly-sinc-xtr no longer works and stut-stut-stut-stutters badly.!

It seems that the CPU is much lower 23% but the GPU is up at 86%. Is there anyway to get HQP to use a little less GPU and a little more CPU to allow me play poly-sinc-xtr?


Also I am getting dropouts for about a second or two which are a new phenomenon ( predates driver update - first occurred last night with Tidal content but happened just now with music from hard drive . Any ideas what may be happening here.

the drop put is pretty clear from the task manager.


Really hard to say… Happens on both CPU and GPU. Maybe power management? You could try to select High Performance power profile from Control Panel / Power.

Now the CUDA seems to be functional. Previously it clearly wasn’t…

Unfortunately no, it is not possible to sensibly do finer grained work split than is currently being made.

Turning off CUDA offloading doesn’t go back to how it was before?

No, there is stuttering with CUDA switched off (and always was).