Crackles when upsampling in Roon 1.3 after upgrade to build 200

I am running Roon Core on Ubuntu (NUC 6I5SYK - 8MB RAM and 120 GB SSD), that is also running KODI. Ever since the last update to build 200, when I try to upsample, be it in PCM or DSD, I’ve been getting crackles… it seems if I were to upsample more, i.e. to DSD256 instead of DSD64, the crackles are becoming more and more…

FYI - I am connecting my USB DAC with Roon Bridge on Pi 3B that is connected to the network via Wifi.

Can you please give me some pointers to look into this issue… is this because of the build 200, or is there something else? Previously when I started with Roon 1.3, this issue was not there.


I’ve noticed this too.

Don’t know if it’s due to overruns in the buffer or timing errors somewhere in the chain.

I wonder if the Roon Core and Bridge should have FIFO enabled by default on what ever OS they are installed on…? As well as some possible priority settings.

It’s because wifi connection to your RPi cannot handle the data rate of DSD

If this is the case then perhaps an adjustment to the MTU can help.

Way back a long time ago the MTU value was established at 1500 but since then Gigabit LAN and Adapters we can actually use and benefit from 9000 value.

Just make sure your Router is also set at MTU=9000 as well as the Core and Bridge. Other router adjustments like Jumbo frames etc. can also help.

On Linux you can use Ethtool which allows you to change and modify your Ethernet settings.

netstat -i <----will provide you with the current settings

To change the MTU settings and make it persistent you can modify the file


Then do a
service network restart

Make sure any switches you are using will pass jumbo frames too.


Thanks Edward, I’ll try this tonight.

@mvrlogins - I did suspect the wifi connection but i didn’t have this problem with the previous build, and also not when i was trialling HQPlayer. This is why i suspect there’s something else that I need to look into.

I could be wrong but I seem to remember jumbo frames aren’t supported with Roon. If you want DSD256 I don’t think a raspberry pi is the right device. Interesting that it worked previously though.