Crashed My QNAP Server Again


Hey guys - still issues here. Just did a “restart” to bring up the new release on my QNAP NAS. Now I’m back in the endless loop Authorization Screen on my Win10 PC/ “Oops Meant to Run As Remote” / Choose between PC and NAS - NAS has “Ready” next to it / Click “Connect” under NAS / back to “authorizations” Screen and repeat the whole mess.

Your handling of the QNAP package, especially updates, needs work. I shouldn’t have to restart my NAS to update your program.

I have never had to restart my QNAP TVS-471 EVER to update Roon. You have something else going on there.

“STOP” the Roon app first, then update the NAS.
“START” the Roon app after update NAS.

Just to add - my QNAP is not showing the current build. It’s showing Build 298 v1.4 qpkg 10-03-17. Since its impossible to wade through the wall of text on your webpage to find the current build, I cant manually update either.

I’m using a different model, for one thing. The fact that you don’t have the issue is regretfully not authoritative.

What do you mean “update the NAS”? The info I got on starting up Roon today said everything would update automatically and I just needed to click the Update button for the NAS to update.

There is no need to stop/start the app, if you just want to update to a new build of RoonServer. This should happen within Roon.
Maybe I misunderstood your post, so can you give more details what you did to come to this state?

I started Roon on my Win 10 box. I got a screen that said a new build was available. It started downloading the Win10 software. Under that was a note that said a new stable build for my QNAP was available with a button that said something like “restart Roon”. I clicked on that button. First I briefly got a “lost connection” screen. Then the screen I describe in my first message above which is just an endless loop. Roon is running on my NAS, but none of my clients are able to connect to it as core.

I agree with you. You are saying its the QNAP package when there are many other users that don’t have your issue. Perhaps ask for help first before you blame the software. You have a local issue that you will get worked out with help from others in the community. Will you come back and point out that it was not the package then?

Uh… I’m posting in the community support forums to describe a Roon software issue. I have no idea why you feel the need to jump in and “defend” Roon. The fact that my configuration brings out a Roon software bug and yours does not is what software bug chasing is all about. Do a search for QNAP in these forums and you’ll find a long list of issues that neither of us have. Therefore what?

I can post a series of screen shots showing the “loop” if that would help.

When you figure it out just post what it was. It ain’t gonna be that QNAP or the QNAP package because your problem is with the Roon build not the QNAP package. You had your terminology a bit turned around. It’s all good. Good luck getting it sorted out.

I guess I’m not following what you see as the difference between the “Roon build” and the “QNAP package.” I assume that Roon provides the package to QNAP. And all clients are down which suggests whatever has gone sideways is on the server. Where are you suggesting I look?

You updated the QNAP build to 298. You did not update your QNAP package which is a separate piece of software that enables the Roon software to run on your QNAP. Crieke is the resident QNAP expert here. Respond to his posts and I am sure he will get you up and running in no time. Good luck.

Ok, interesting. First I’ve heard that QNAP applications are updated separately from the “package” that you initially install. I have a couple of apps that have to be manually updated and I have to download a new “package” [ie, a file ending in qpkg]. Anyway, thanks and regards.


Restarting the server has not helped. I am permanently stuck in the loop I described above.

Attached are images of the screens I get on all devices. Remotes refuse to connect to the core on my QNAP even though, as you see, the core reports itself as ready. I simply go back and forth between these two screens.


Further tests:

  1. Went to “Advanced” on the QNAP and reinstalled Build 298. Clients still fail.

  2. Since when I first installed the software on my Win10 PC, I wasn’t aware of the QNAP capability and had it set as the core I completely uninstalled the remote on my PC. iOS clients still stuck in permanent Authorization loop.


Do you mean by “permanent authorization loop”, that you can’t authorize the qnap core again?
I was just wondering, if your qnap RoonServer just lost its authorization. Just speculating, but maybe you authorized unintentionally your iMac or another device at any point.

There is no harm in trying to enter your credentials again and clicking the the Unauthorize button next to the GaladrielGray device. I’d be interested to hear if this is just a lost authorization or actually a new set of database…
I have no scenario in mind, how it could happen that RoonServer starts with a new database (except you press the “Reset”-database button in the web administration).

If you look at the two pictures I uploaded, what I mean by “permanent,etc” should be more clear. I go back and forth between the two screens indefinitely. When I click on “Connect” on the screen showing the QNAP as ready, I get the “Authorizations” screen shown. On that screen, when I click on “Oops, I meant…etc” I go back to the screen showing the PC and the QNAP as “Ready.” This constant loop between these two screens occurs on every remote control device.

There was no accidental authorizing of my PC. As I’ve mentioned before, when I first tried Roon, I set up my PC as the core, not knowing that the QNAP core was available. I decided I wasn’t interested. Then I later learned of the QNAP version and installed and authorized it. This configuration was attractive, so I bought the lifetime license. The day I bought my license this same problem appeared.

I do not believe this to be a QNAP problem per se. I believe there is a bug in the authorization module that my PC Core - move to QNAP Core - buy license sequence has uncovered and that came out again with the build upgrade. It is disturbing that Roon support has been conspicuously absent. Not what I would expect given the price point of this product. No disrespect of your efforts intended, I’m assuming from the profile info I see you’re not an actual employee.

Adding in support @support