Crashed My QNAP Server Again

Uh… I’m posting in the community support forums to describe a Roon software issue. I have no idea why you feel the need to jump in and “defend” Roon. The fact that my configuration brings out a Roon software bug and yours does not is what software bug chasing is all about. Do a search for QNAP in these forums and you’ll find a long list of issues that neither of us have. Therefore what?

I can post a series of screen shots showing the “loop” if that would help.

When you figure it out just post what it was. It ain’t gonna be that QNAP or the QNAP package because your problem is with the Roon build not the QNAP package. You had your terminology a bit turned around. It’s all good. Good luck getting it sorted out.

I guess I’m not following what you see as the difference between the “Roon build” and the “QNAP package.” I assume that Roon provides the package to QNAP. And all clients are down which suggests whatever has gone sideways is on the server. Where are you suggesting I look?

You updated the QNAP build to 298. You did not update your QNAP package which is a separate piece of software that enables the Roon software to run on your QNAP. Crieke is the resident QNAP expert here. Respond to his posts and I am sure he will get you up and running in no time. Good luck.

Ok, interesting. First I’ve heard that QNAP applications are updated separately from the “package” that you initially install. I have a couple of apps that have to be manually updated and I have to download a new “package” [ie, a file ending in qpkg]. Anyway, thanks and regards.


Restarting the server has not helped. I am permanently stuck in the loop I described above.

Attached are images of the screens I get on all devices. Remotes refuse to connect to the core on my QNAP even though, as you see, the core reports itself as ready. I simply go back and forth between these two screens.


Further tests:

  1. Went to “Advanced” on the QNAP and reinstalled Build 298. Clients still fail.

  2. Since when I first installed the software on my Win10 PC, I wasn’t aware of the QNAP capability and had it set as the core I completely uninstalled the remote on my PC. iOS clients still stuck in permanent Authorization loop.


Do you mean by “permanent authorization loop”, that you can’t authorize the qnap core again?
I was just wondering, if your qnap RoonServer just lost its authorization. Just speculating, but maybe you authorized unintentionally your iMac or another device at any point.

There is no harm in trying to enter your credentials again and clicking the the Unauthorize button next to the GaladrielGray device. I’d be interested to hear if this is just a lost authorization or actually a new set of database…
I have no scenario in mind, how it could happen that RoonServer starts with a new database (except you press the “Reset”-database button in the web administration).

If you look at the two pictures I uploaded, what I mean by “permanent,etc” should be more clear. I go back and forth between the two screens indefinitely. When I click on “Connect” on the screen showing the QNAP as ready, I get the “Authorizations” screen shown. On that screen, when I click on “Oops, I meant…etc” I go back to the screen showing the PC and the QNAP as “Ready.” This constant loop between these two screens occurs on every remote control device.

There was no accidental authorizing of my PC. As I’ve mentioned before, when I first tried Roon, I set up my PC as the core, not knowing that the QNAP core was available. I decided I wasn’t interested. Then I later learned of the QNAP version and installed and authorized it. This configuration was attractive, so I bought the lifetime license. The day I bought my license this same problem appeared.

I do not believe this to be a QNAP problem per se. I believe there is a bug in the authorization module that my PC Core - move to QNAP Core - buy license sequence has uncovered and that came out again with the build upgrade. It is disturbing that Roon support has been conspicuously absent. Not what I would expect given the price point of this product. No disrespect of your efforts intended, I’m assuming from the profile info I see you’re not an actual employee.

Adding in support @support

Did you read

If not you might have missed this…

" This project was a collaboration between the Roon Team and a member of the Roon community: Chris Rieke!

Chris had started working on the Synology version of Roon Server on his own, so we contacted him and arranged to work together on these projects. Chris will be involved in the maintenance and support for both of these NAS packages in the future. "

So, when it comes to NAS packages, @crieke is a good resource for discussing issues.

I do appreciate his efforts as I said. I get these kinds of relationships - for example I run the Merlin fork of ASUS router firmware.

But this may not be a QNAP issue, so Roon support needs to not be invisible.

Hey @William_Coney – my theory from last time still seems like a possibility here:

I’m double checking there isn’t a more obscure case I’m not thinking about, but when a Windows install is only running as a Remote, the options should be “Connect” (meaning “use this device as a Remote”) and “Setup” (meaning “setup this device as a Core”).

You can see those two options here:

Your screenshot, however, doesn’t say Setup – it says “Continue” which implies that it’s been set up to run as a Core.

What happens if you hit “Continue” on This PC? If you end up with Roon running independent of the NAS, I’m guessing logging out Roon on the Windows machine (Settings > Account) will fix the authorization issue, since then the NAS will be the only Core running.

Another alternative is to just find your database on the Windows machine (instructions here) and rename the Roon folder to something else, like roon_old. Then you can do a fresh remote install on that machine and get a clean test there.

Let us know how it goes @William_Coney.

Well, I think the issues are close to what you’re observing. As I’ve said before, I originally downloaded Roon and set it up on my PC as Core. Wasn’t very happy with using my PC this way but before the trial was up i discovered the QNAP package and installed it. I de-authorized the PC as Core and authorized the server. After a few days I was convinced and bought the lifetime subscription. The day the subscription kicked in [which may also have been the day there was the last before most recent build update] I had exactly this problem of being being caught in an un-authorizable loop. That time I rebooted the server and everything worked. This time I clicked the Roon icon on my PC [now supposedly running as a remote] and got a window saying there was a build update. It showed the PC version as downloading and the QNAP server version as “ready to restart” to update the build. I clicked the restart button and I was back to endless loop mode. Restarting the QNAP didn’t work. Reinstalling the latest build on the QNAP didn’t work. Turning off the PC and only using remotes that were never “Core” didn’t work.

What worked this time was completely uninstalling the software from my PC [including all files, etc] and restarting the server. Then testing with iOS devices and finding that everything was now working. Then I reinstalled the Remote software on my PC and found it still worked.

So there is some glitch / bug / leftover config file / registry key that seems to have triggered this odd behavior when the build update was installed. The PC version seems to revert to thinking its a core while the QNAP server at the same time reports itself as the Core. I really don’t want to waste 4 hours every time there’s a build update. Maybe the next update we can figure out a way to check what’s going on? Its also possible that deleting the Core off my PC and reinstalling only the remote piece is a permanent fix.

Ok. Understood the situation. As you probably know this message normally pops up when you start with a clean install (without a database) or if there is something wrong with the authorization of the core.

It would be helpful, to know which of the 2 cases apply here. I’d try to click the Connect button again, to connect to your QNAP core and then click the Unauthorize button below the devices headline. So you can reassign the authorization to your QNAP.

I know this is not how it should work, but it would help to understand what the issue is about. And in case of an authorization issue, it might get you back to a working state…

Some of this is similar to a problem I reported earlier in January (Admin Login Fail (SAMBA)). Both problems occurred after an installation was changed from a core to a controller and then the controller was updated to a new version. Don’t know what the problem is but you might see if a clean instal fixes it.

Actually, I did try that along the way. In other words, as you suggested I clicked on “Deauthorize” to deauthorize the QNAP and then reauthorized it. Still stuck in the loop. Regardless of what I did with the server, the updated PC build still seemed to see itself as a Core. Removing the PC software in its entirety, old databases and all, was the only way to get things running again.

At this point I’m working again, but I’m certainly open to anything you’d like to try if it helps figure out what’s going on.

Thanks and regards.

I think you’re right about cause. And de- installing the former core seems to have been a key piece of fixing it.

And it just occurred to me that another piece of the puzzle may be that when I installed QNAP and set it up as Core, I didn’t migrate the database over, I just created a new one. So when the build update occurs, the PC software comes up and finds itself sitting on a database but with another device elsewhere on the network authorized. Kind of reminds me of the old Unix NetHack game that, if it thought you were messing with it’s files in order to cheat, would respond “I detect trickery!” And immediately shutdown.