Created a playlist now client dies when I fire it up

@support - I am running Roon Server on a headless Windows 10 PC and have two attached Windows 10 PCs that run both Control and Output. I used one of them to create a Christmas play list for the other to play. The other PC is working fine, but the one that I used to create the playlist now dies as soon as I fire up Roon. I get a brief glimpse of the playlist, but that it is it, can you help ?

Hello @Richard_Chantry,

What exactly do you mean by “the playlist dies as soon as I fire up Roon”? What are you seeing? Is Roon completely crashing or does just that playlist not load? If you can provide a screenshot that would help clarify things a bit.


1 Like

Hi Noris

Many thanks for your email and getting back to me on Christmas day too.

By the way I have solved my problem by doing the following –

(1) A complete uninstall and re-install of my Roon core on the windows 10 PC that I exclusively run Roonserver on.
(2) A complete uninstall and reinstall of the 64 bit Roon software on the Windows 10 PC that I used to create the Playlist and where Roon was crashing (downstairs PC)
(3) I restored the Roon core library on the Roon core PC from the last backup.

The Playlist is no more but I can live without it for the time being as it was a one off, of Christmas music, that I played on Christmas day.

As I mentioned, I have three Windows 10 Home Edition PCs. One dedicated to running the core, and an upstairs and a downstairs PC that I use to listen to Roon.

I created my first ever playlist of about 12 Christmas songs on the down stairs PC with the plan of playing the playlist upstairs on Christmas morning.

On Christmas day I opened up the playlist in Roon on the upstairs PC but discovered that it only had six pieces of music on it. I confirmed this by opening up the playlist downstairs. I still had 10 minutes or so before I needed to play the playlist so I added the missing 6 tracks to it using my downstairs PC. The playlist was still open on the upstairs PC and very cleverly Roon upstairs showed the playlist with the full 12 tracks automatically. I then shut down Roon on the downstairs PC and we successfully played all 12 tracks, from the playlist, on the upstairs PC. We then went onto play other pieces later in the afternoon on the upstairs PC.

Later that evening I tried, many times, to fire up Roon on the downstairs PC, it would briefly show the playback screen for the last piece that I added to the playlist, then end with no error message.

As I mentioned, I have got Roon back up and running now. I suspect the problem was caused by the fact that I was adding to a playlist from the Downstairs computer that I had open on the upstairs computer. Perhaps you could get a Dev at Roon to look at this because it should be pretty simple to reproduce.

Many thanks for your help and a very Merry Christmas.



Hello @Richard_Chantry,

It sounds to me like something has gone wrong with Roon your downstairs PC’s Roon Remote. Can you confirm that the downstairs PC is used only as a Roon Remote? If so I would advise to re-install Roon Remote on that PC and double check that the Database Location is empty after removing the Roon Remote.

Unfortunately checking the logs after a Database Restore is not possible since you have overwritten that information by restoring. I would proceed to reinstall Roon Remote and if you experience any other issues in the future please let me know a timestamps (ex. 9:22PM) and we can take a look at the diagnostics from that machine.


Hi Noris

Many thanks for the time and effort that you put into looking at my Roon Playlist problem.

I can confirm that the problem is now fixed via the 3 steps that I took to get Roon back up and running, and that I detailed in my previous post.

You can go ahead and close this issue as fixed now. Should anyone else stray into (the probably quite unusual) Playlist problems that I encountered, hopefully there is now a documented fix or maybe some further ideas for them, as to how to resolve the problem.



Thanks for letting me know @Richard_Chantry, hope you have a great day!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.