Creation of ROCK installation Key on Mac OSX Ventura 13.1

Hi everyone,

Need some help here… I bought a NUC (NUC11TNH) in order to install ROCK on it.

I work on a Mac M1 (osX 13.1 Ventura). I downloaded the image file. However, I get stucked when I try to create the bootable USB Key… I tried with Etcher from Balena, and though I can select both the file and the USB drive I wanna use, Etcher is starting quickly before having the drive disappearing…

I also tried the Terminal method, but unsuccessfully…

Any idea what I can do to get it to work !

Thanks in advance,

I had a number of issues with this exact issue. Can finder or disk utilities see that you have a usb key inserted? For me the issue was not that the Mac could see it and balena could not but that balena was accurately representing what the Mac was seeing. I ended up needing to try a few different USB keys - I had a lot lying around. Good luck!

I had the same issue with the latest version on balenaEtcher on macOS Ventura. An earlier version of Etcher solved my problem.

Dear Wybe, where can we find an earlier version of Etcher?
Thanks in advance to help us as well!

Not sure, but, I use rufus instead of etcher. You might try that.

I don’t recall the website, but I do know that I’m using balenaEtcher 1.7.3. now. That version works with macOS Ventura.

Go with Rufus. Balena works for me sometimes on Mac and sometimes not.

Are you logged in as an admin? I couldn’t get it to work under a standard account, but no problem as an administrator.

There is no Rufus for macOS, is there?

This is caused, probably, by new Mac OS being super paranoid about the kind of write access needed to burn images. Try this…

or you can try running it as root (superuser) from terminal like:
sudo /Applications/

Please use Raspberry Pi Imager. balenaEtcher somewhat is not that reliable.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.