Crestron Extension Settings has no zone choices


(Larry Basham) #1

I have the Crestron Extension in the Roon Settings. What I don’t get are the 4 “zones” dropdown boxes to choose my players. I have gone through the ‘Cannot see Crestron Extension in Roon?’ topic. I imagine trying things like re-compiling all in SIMPL, reloading, rebooting the Nucleus, re-add the extension in Roon settings… I have tried this 3-4 times with no luck at all. What am I missing here? Thanks guys


(Larry Basham) #2

Here is an example of what happens. After doing all the reloads and reboots and add the Crestron extension in settings, Crestron does not show up as a discovered extension (but my control 4 does). However, if I look at Authorized Extensions, the Crestron (and Control 4) shows up.


Thanks


(Noris) #4

Hello @Larry_Basham,

Thanks for contacting us regarding this issue, can you please confirm for me which Crestron processor model you are using? I would also make sure that the Nucleus and the Roon Core are on the same subnet, Roon will not work properly across different subnets or multiple VLANs.

It appears that the extension did connect successfully at one point, I would go ahead and remove it from the Extension Authorizations, perform a Recompile All in SIMPL and reupload the module then reboot both the Nucleus and the Crestron processor. Please let me know if that helps.

Thanks,
Noris


(Larry Basham) #5

I tried again this morning. I am using an MC3 on my desk. We are not using VLANS, everything is on the same subnet. I performed all these steps again, and I am able to add the extension for Crestron, but the settings page to select my “zone” or player to use, they are not there.
Toolbox after reboot of MC3
Here are scree

nshots again after each load and reboot.

Roon server after reboot

Roon software settings showing Crestron extensions

Roon software after adding extension and checking the settings to add zones

Thanks for the help, hopefully we can get it figured out.


(Noris) #6

Hello @Larry_Basham,

Thanks for sharing those screenshots. I believe I recognize the issue here –
You need to first update your Nucleus to the newest firmware version, please take a look at this page (https://kb.roonlabs.com/Updating_Nucleus).

I would perform the update in the following order:

  • Update the Nucleus firmware
  • Restart the Nucleus
  • Restart the MC3 processor
  • Perform a recompile all in SIMPL
  • Upload the program once more to your processor

Please let me know if that helps.

Thanks,
Noris


(Larry Basham) #7

That did it. thank you


(Noris) #8

Happy to help @Larry_Basham! Any other questions you may have just let me know.

Thanks,
Noris