Crossfade not working at all

I’m new to roon and loving it ! (Just discovered yaeji)
However I have a habit of changing songs midstream during parties and the sudden stop and short gap between songs aren’t great. I’ve set the zone cross fade for 3sec but no luck. Not sure if I’m missing some pcm setting to enable crossfade? Any help greatly appreciated - I’ve searched this and other forums and can’t find a solution - everyone seems to have crossfade working off the bat once set and simply have tweaking issues rather than no cross fade at all… thanks !

Hi @alan_Garcia ---- Thank you for the report and sharing your feedback with us. Both are appreciated! Very pleased to hear you’ve been enjoying Roon :sunglasses:

Moving forward, may I very kindly ask you to please provide me with the following information:

  • A brief but accurate description of your current setup, using this link as a guide.

  • Please provide screenshots of…

    • Your signal path leaving Roon when you make this observation.

    • The playback setting being used when you make this observation. This information can be found under “device setup”.

  • During your troubleshooting have you tried testing with “resync delay” enabled?


Are you pressing Next? Crossfade is only designed to work at the track boundary, meaning if you let one song finish and naturally fade into the next track.